aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-08 15:50:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-09 21:05:19 +0100
commit6aaa7beb622496c250174ae67ac9c8006e2b06d8 (patch)
tree1cbeeff2c4a4528705964c7d7e7980c61049e184 /gnu/packages/golang-web.scm
parentd97832e5b74df74f0b7bd28aa09a0a85cc67f250 (diff)
downloadguix-6aaa7beb622496c250174ae67ac9c8006e2b06d8.tar.gz
guix-6aaa7beb622496c250174ae67ac9c8006e2b06d8.zip
gnu: Add go-github-com-mdlayher-socket.
* gnu/packages/golang-web.scm (go-github-com-mdlayher-socket): New variable. Change-Id: I8c116aef364f384fec098538210001e11f38b0ff
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 9c7f722a13..6e2633c761 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3128,6 +3128,35 @@ supported by HTTP PATCH method, allowing for standards based partial updates
via REST APIs.")
(license license:asl2.0)))
+(define-public go-github-com-mdlayher-socket
+ (package
+ (name "go-github-com-mdlayher-socket")
+ (version "0.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mdlayher/socket")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bq6sphsffjqqk2v9wy8qkv5yf0r6d72pklapgy3znqlnpgvnqab"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mdlayher/socket"))
+ (native-inputs
+ (list go-github-com-google-go-cmp))
+ (propagated-inputs
+ (list go-golang-org-x-net go-golang-org-x-sync go-golang-org-x-sys))
+ (home-page "https://github.com/mdlayher/socket")
+ (synopsis "Low-level network connection type with async I/O and deadline support")
+ (description
+ "This package provides a low-level network connection type which
+integrates with Go's runtime network poller to provide asynchronous I/O and
+deadline support.")
+ (license license:expat)))
+
(define-public go-github-com-microcosm-cc-bluemonday
(package
(name "go-github-com-microcosm-cc-bluemonday")