aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-21 21:50:48 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commit48f7e826d2a688966ce39019279d3e30ca5018a7 (patch)
treef037da876d6c17a372d64ea75b5470e503bd6668 /gnu/packages/golang-web.scm
parentbb6c91c9b9a924a8af87aad324960974f4a5ea8c (diff)
downloadguix-48f7e826d2a688966ce39019279d3e30ca5018a7.tar.gz
guix-48f7e826d2a688966ce39019279d3e30ca5018a7.zip
gnu: Add go-github-com-shurcool-vfsgen.
* gnu/packages/golang-web.scm (go-github-com-shurcool-vfsgen): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I7f89b17c4950b68147922fac0fea49fa527a9172
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b7a1b71d0b..8f00b0e351 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3670,6 +3670,35 @@ interface.")
use gzip compression when serving HTTP requests.")
(license license:expat)))
+(define-public go-github-com-shurcool-vfsgen
+ (package
+ (name "go-github-com-shurcool-vfsgen")
+ (version "0.0.0-20230704071429-0000e147ea92")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/vfsgen")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ypfdiv56ckb0yc7mccc2l8vc3gmfws2p7bcf9f0j415m7r0aq6q"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/shurcooL/vfsgen"))
+ (native-inputs
+ (list go-golang-org-x-tools))
+ (propagated-inputs
+ (list go-github-com-shurcool-httpfs))
+ (home-page "https://github.com/shurcooL/vfsgen")
+ (synopsis "Generate Go code from an @code{http.FileSystem}")
+ (description
+ "Package @code{vfsgen} takes an @code{http.FileSystem} (likely at
+@code{go generate} time) and generates Go code that statically implements the
+provided @code{http.FileSystem}.")
+ (license license:expat)))
+
(define-public go-github-com-sourcegraph-jsonrpc2
(package
(name "go-github-com-sourcegraph-jsonrpc2")