aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 11:44:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 13:15:39 +0100
commit4412d0e160824eaa402ae21f990969e279b387d0 (patch)
tree365992fc1e86d55b400a896f65ef15a4fc57988a /gnu/packages/golang-web.scm
parentddeb0130549014c2b3f3c52766ae8bbd4f7265f0 (diff)
downloadguix-4412d0e160824eaa402ae21f990969e279b387d0.tar.gz
guix-4412d0e160824eaa402ae21f990969e279b387d0.zip
gnu: go-mvdan-cc-xurls: Move to golang-web.
* gnu/packages/golang.scm (go-mvdan-cc-xurls, xurls): Move from here... * gnu/packages/golang-web.scm: ... to here. * gnu/packages/messaging.scm: Add golang-web module. Change-Id: I990e5dff7d5813dc4b1c40e9a7707901235af458
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 5c1ece7389..66b6050b17 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3683,6 +3683,34 @@ Signing and Encryption set of standards. This includes support for JSON Web
Encryption, JSON Web Signature, and JSON Web Token standards.")
(license license:asl2.0)))
+(define-public go-mvdan-cc-xurls
+ (package
+ (name "go-mvdan-cc-xurls")
+ (version "2.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mvdan/xurls")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1516hwlxbnhdca56qy7sx9h2n5askq6ddqpqyp3f5rvmzdkxf4zn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "mvdan.cc/xurls/v2"))
+ (propagated-inputs
+ (list go-github-com-rogpeppe-go-internal
+ go-golang-org-x-mod
+ go-golang-org-x-sync))
+ (home-page "https://mvdan.cc/xurls/v2/")
+ (synopsis "Extracts URLs from text")
+ (description
+ "Xurls extracts urls from plain text using regular expressions. It can
+be used as both a binary and a library.")
+ (license license:bsd-3)))
+
(define-public go-nhooyr-io-websocket
(package
(name "go-nhooyr-io-websocket")
@@ -3747,6 +3775,22 @@ go-github-com-multiformats-go-multiaddr-dns.")))
(description "This package provides a CLI binary executible built from
go-github-com-tdewolff-minify-v2 source.")))
+(define-public xurls
+ (package
+ (inherit go-mvdan-cc-xurls)
+ (name "xurls")
+ (arguments
+ (list
+ #:import-path "mvdan.cc/xurls/v2/cmd/xurls"
+ #:unpack-path "mvdan.cc/xurls/v2"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file "testdata/script/version.txtar")))))))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar