aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:55:00 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:55:00 +0100
commit389bf59aed5faedfd4aecb010b16eb2cbced5f30 (patch)
treec2a6354c9a1099bae21a22257009d0a638e07a74 /gnu/packages/golang-web.scm
parent892c4cace7ae8c366e423366f5094a37486ffc59 (diff)
downloadguix-389bf59aed5faedfd4aecb010b16eb2cbced5f30.tar.gz
guix-389bf59aed5faedfd4aecb010b16eb2cbced5f30.zip
gnu: go-github-com-emersion-go-smtp: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-emersion-go-smpt): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I5df22126cc7bdd541e33661996e7753e2cd732ea
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 70397c311f..5c1ece7389 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -959,6 +959,32 @@ for Go.")
"This package provides a SASL library written in Go.")
(license license:expat))))
+(define-public go-github-com-emersion-go-smtp
+ (package
+ (name "go-github-com-emersion-go-smtp")
+ (version "0.21.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-smtp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0drvmvrkmhqhnv4m3my1hbkyyva2vi35b36j0pdi57xc9rflziq3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-smtp"))
+ (propagated-inputs
+ (list go-github-com-emersion-go-sasl))
+ (home-page "https://github.com/emersion/go-smtp")
+ (synopsis "SMTP implementation for Go")
+ (description
+ "This package implements the Simple Mail Transfer Protocol as defined by
+RFC 5321.")
+ (license license:expat)))
+
(define-public go-github-com-emicklei-go-restful
(package
(name "go-github-com-emicklei-go-restful")