aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 22:31:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 22:31:05 +0100
commit2657da33fd5fb4a4faf8e450436756c2a6c33b81 (patch)
treee5bcf27e0811b6dee29caeef7e79d2a5880f12ea /gnu/packages/golang-web.scm
parentd7b4f8f33587b7d519dccc94514a2aebd25a2908 (diff)
downloadguix-2657da33fd5fb4a4faf8e450436756c2a6c33b81.tar.gz
guix-2657da33fd5fb4a4faf8e450436756c2a6c33b81.zip
gnu: go-github-com-libp2p-go-flow-metrics: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-libp2p-go-flow-metrics): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I6847de630820dc895cb3d14f16b086fd1cc69bb7
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d4b4c4043f..e0a83a03c7 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2633,6 +2633,34 @@ router.")
@acronym{Simple Service Discovery Protocol, SSDP}} library for Golang.")
(license license:expat)))
+(define-public go-github-com-libp2p-go-flow-metrics
+ (package
+ (name "go-github-com-libp2p-go-flow-metrics")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-flow-metrics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13yb68vrcn2zdi0mjjh17dphfxl6y99bkq0ia53hasyfj6l6626h"))))
+ (build-system go-build-system)
+ (arguments
+ ;; XXX: Tests may hang sometimes, see
+ ;; <https://github.com/libp2p/go-flow-metrics/issues/30>.
+ (list
+ #:import-path "github.com/libp2p/go-flow-metrics"))
+ (propagated-inputs
+ (list go-github-com-benbjohnson-clock))
+ (home-page "https://github.com/libp2p/go-flow-metrics")
+ (synopsis "Simple library for tracking flow metrics")
+ (description
+ "A simple alternative to rcrowley's @command{go-metrics} that's a lot
+faster (and only does simple bandwidth metrics).")
+ (license license:expat)))
+
(define-public go-github-com-libp2p-go-nat
(package
(name "go-github-com-libp2p-go-nat")