aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-21 21:28:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:46 +0100
commit1c8451d0bab3429d176a89fa1ebf3264bdf8fd95 (patch)
tree697e590e148db2f6b670da918732b42eca0fc7c8 /gnu/packages/golang-web.scm
parent01d65dfa0492ddc35328ddba341e51b518675e42 (diff)
downloadguix-1c8451d0bab3429d176a89fa1ebf3264bdf8fd95.tar.gz
guix-1c8451d0bab3429d176a89fa1ebf3264bdf8fd95.zip
gnu: Add go-github-com-puerkitobio-urlesc.
* gnu/packages/golang-web.scm (go-github-com-puerkitobio-urlesc): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: If2cbb27f329e681bf83615ff82cc4f6a9a34804e
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1f1a030852..a52e02cf6d 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3428,6 +3428,32 @@ to jQuery to the Go language.")
described in @url{http://tools.ietf.org/html/rfc3986#section-6, RFC 3986}.")
(license license:bsd-3)))
+(define-public go-github-com-puerkitobio-urlesc
+ (package
+ (name "go-github-com-puerkitobio-urlesc")
+ (version "0.0.0-20170810143723-de5bf2ad4578")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PuerkitoBio/urlesc")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n0srpqwbaan1wrhh2b7ysz543pjs1xw2rghvqyffg9l0g8kzgcw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/PuerkitoBio/urlesc"))
+ (home-page "https://github.com/PuerkitoBio/urlesc")
+ (synopsis "Proper URL escaping as per RFC 3986")
+ (description
+ "Package @code{urlesc} implements query escaping as per
+@url{https://rfc-editor.org/rfc/rfc3986.html,RFC 3986}. It contains some
+parts of the @code{net/url} package, modified so as to allow some reserved
+characters incorrectly escaped by net/url.")
+ (license license:bsd-3)))
+
(define-public go-github-com-quic-go-qpack
(package
(name "go-github-com-quic-go-qpack")