aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:44:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:44:14 +0100
commit1434e3aeeab176d6271f912066a0b4eb18bd7759 (patch)
treef5cc6daf5ab2c0c8980a289abc0a63dfd7d2851c /gnu/packages/golang-web.scm
parent35438093a48b2cc1ce600f5a24b38ca1363df29e (diff)
downloadguix-1434e3aeeab176d6271f912066a0b4eb18bd7759.tar.gz
guix-1434e3aeeab176d6271f912066a0b4eb18bd7759.zip
gnu: go-github-com-emersion-go-msgauth: Enable tests.
* gnu/packages/golang-web.scm (go-github-com-emersion-go-msgauth): Enable tests. [arguments]: <#:phases>: Add custom 'check phase. Change-Id: I126a688146bc4e47980f4046fd3118008520fe70
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 02c1262b0d..4d9f0c0882 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -914,11 +914,16 @@ for Go.")
(arguments
(list
#:import-path "github.com/emersion/go-msgauth"
- #:tests? #f ; Source-only package.
#:phases
#~(modify-phases %standard-phases
- ;; Source-only package.
- (delete 'build))))
+ ;; XXX: Run all tests, workaround for go-build-system's lack of Go
+ ;; modules support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(propagated-inputs
(list go-golang-org-x-crypto
go-github-com-emersion-go-milter