aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 21:21:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 21:21:30 +0100
commit0a46e960d0a91a22853a7ad9b24422d07bc12a8c (patch)
tree78825f85d564ebe6ae3fd7536cbff12b1e183f7b /gnu/packages/golang-web.scm
parent5eb7bb7c2c4d70a397e6c724f6ea750f67515b2c (diff)
downloadguix-0a46e960d0a91a22853a7ad9b24422d07bc12a8c.tar.gz
guix-0a46e960d0a91a22853a7ad9b24422d07bc12a8c.zip
gnu: go-github-com-miekg-dns: Move to golang-web.
* gnu/packages/golang-xyz.scm (go-github-com-miekg-dns): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I7d1e38dd4fdc9578cdefdf01ff43f5201c490f73
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b36a618e56..d4b4c4043f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
@@ -2835,6 +2836,46 @@ via REST APIs.")
(description "@code{bluemonday} is a HTML sanitizer implemented in Go.")
(license license:bsd-3)))
+(define-public go-github-com-miekg-dns
+ (package
+ (name "go-github-com-miekg-dns")
+ (version "1.1.62")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/miekg/dns")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wdsacp4ay6ji72vnszq6ksn5n060z2hv94wgjsn0pr7gpa3nk6c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/miekg/dns"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; Unable to run test server.
+ (("TestIsPacketConn") "OffTestIsPacketConn"))))))))
+ (propagated-inputs
+ (list go-golang-org-x-tools
+ go-golang-org-x-sys
+ go-golang-org-x-sync
+ go-golang-org-x-net))
+ (home-page "https://github.com/miekg/dns")
+ (synopsis "Domain Name Service library in Go")
+ (description
+ "This package provides a fully featured interface to the @acronym{DNS,
+Domain Name System}. Both server and client side programming is supported.
+The package allows complete control over what is sent out to the @acronym{DNS,
+Domain Name Service}. The API follows the less-is-more principle, by
+presenting a small interface.")
+ (license license:bsd-3)))
+
(define-public go-github-com-multiformats-go-multiaddr
(package
(name "go-github-com-multiformats-go-multiaddr")