aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 23:33:41 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 23:33:41 +0100
commit0508bb1f7d209e24f28e4a847ab4f866f95e2534 (patch)
tree77b8834d297f3035bf16726a4f7a05e0da0a7403 /gnu/packages/golang-web.scm
parent9f3e8c045f4c8fb652fa8da0705a41eb60f05808 (diff)
downloadguix-0508bb1f7d209e24f28e4a847ab4f866f95e2534.tar.gz
guix-0508bb1f7d209e24f28e4a847ab4f866f95e2534.zip
gnu: go-github-com-jhillyerd-enmime: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-jhillyerd-enmime): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: Ifbc0490421ad5063d6681c46b8e0facca636bd9e
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 007af4ef7c..f1bf859224 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1620,6 +1620,38 @@ SPNEGO Kerberos authentication, as well as a HTTP handler wrapper decodes
Microsoft AD PAC authorization data.")
(license license:asl2.0)))
+(define-public go-github-com-jhillyerd-enmime
+ (package
+ (name "go-github-com-jhillyerd-enmime")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jhillyerd/enmime")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03pir9wq9ha2i2ifj819yv5i0lvrgdn904ksbzgc3k8bqc497ydn"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/jhillyerd/enmime"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-cention-sany-utf7
+ go-github-com-go-test-deep
+ go-github-com-gogs-chardet
+ go-github-com-jaytaylor-html2text
+ go-github-com-pkg-errors
+ go-golang-org-x-text))
+ (home-page "https://github.com/jhillyerd/enmime")
+ (synopsis "MIME encoder and decoder for Go")
+ (description
+ "The enmime package implements a MIME encoding and decoding library
+geared towards parsing MIME encoded emails.")
+ (license license:expat)))
+
(define-public go-github-com-jmespath-go-jmespath
(package
(name "go-github-com-jmespath-go-jmespath")