aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 09:20:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:52 +0100
commite61013a0d8658f4c7eb3cd7020e8dafe69307a4a (patch)
tree43e8e30e5c0b12ddcbd5bc04c8578ef14bc233cf /gnu/packages/golang-crypto.scm
parentb94b99c664ed498e611e6e04db1b439f3a30a98b (diff)
downloadguix-e61013a0d8658f4c7eb3cd7020e8dafe69307a4a.tar.gz
guix-e61013a0d8658f4c7eb3cd7020e8dafe69307a4a.zip
gnu: packages/golang-chrypto: Sort some packages.
Adjust order of some packages and place them in other golang-* ones, it contains inherited packages which produce just executable CLI commands without source installed. * gnu/packages/golang-crypto.scm (age, age-keygen): Move variable to the end of file. Change-Id: I58db45f58c537c1c1d59ca29d89267ddd5f5260c
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm44
1 files changed, 26 insertions, 18 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 0d04e26479..a1c75620b8 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -63,6 +63,10 @@
;;;
;;; Code:
+;;;
+;;; Libraries:
+;;;
+
(define-public go-filippo-io-age
(package
(name "go-filippo-io-age")
@@ -92,24 +96,6 @@ It features small explicit keys, no configuration options, and Unix-style
composability.")
(license license:bsd-3)))
-(define-public age
- (package
- (inherit go-filippo-io-age)
- (name "age")
- (arguments
- `(#:import-path "filippo.io/age/cmd/age"
- #:unpack-path "filippo.io/age"
- #:install-source? #f))))
-
-(define-public age-keygen
- (package
- (inherit go-filippo-io-age)
- (name "age-keygen")
- (arguments
- `(#:import-path "filippo.io/age/cmd/age-keygen"
- #:unpack-path "filippo.io/age"
- #:install-source? #f))))
-
(define-public go-filippo-io-edwards25519
(package
(name "go-filippo-io-edwards25519")
@@ -1363,6 +1349,28 @@ performance for large inputs and outputs.")
(description "GoPtLib is a library for writing Tor pluggable transports in
Go.")
(license license:cc0)))
+
+;;;
+;;; Executables:
+;;;
+
+(define-public age
+ (package
+ (inherit go-filippo-io-age)
+ (name "age")
+ (arguments
+ `(#:import-path "filippo.io/age/cmd/age"
+ #:unpack-path "filippo.io/age"
+ #:install-source? #f))))
+
+(define-public age-keygen
+ (package
+ (inherit go-filippo-io-age)
+ (name "age-keygen")
+ (arguments
+ `(#:import-path "filippo.io/age/cmd/age-keygen"
+ #:unpack-path "filippo.io/age"
+ #:install-source? #f))))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances