;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès ;;; Copyright © 2016 Mark H Weaver ;;; Copyright © 2016 Jan Nieuwenhuizen ;;; Copyright © 2017, 2019 Mathieu Othacehe ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-12 21:58:57 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:40 +0000
commit8bea1e05fac2e24ac926f155d76e42aa90690467 (patch)
tree0f9ad155931e331afed5d083d4bb19777a9aba16 /gnu/packages/golang-crypto.scm
parenta8d5d087086da0e47700781ff858d3d0d2090271 (diff)
downloadguix-8bea1e05fac2e24ac926f155d76e42aa90690467.tar.gz
guix-8bea1e05fac2e24ac926f155d76e42aa90690467.zip
gnu: packages/golang-crypto: Apply #:subdir parameter.
* gnu/packages/golang-crypto.scm (go-github-com-decred-dcrd-crypto-blake256, go-github-com-decred-dcrd-dcrec-secp256k1-v4) [source]: Apply new <#:subdir> parameter for monorepo projects. Change-Id: I85004b257c767ce202129e621d78b285d4578f7a
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 2ba3a530ad..016592e776 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -560,13 +560,7 @@ one-time authenticator as specified in
(method git-fetch)
(uri (git-reference
(url "https://github.com/decred/dcrd")
- (commit (go-version->git-ref
- ;; XXX: While waiting on consensus:
- ;; - https://issues.guix.gnu.org/52362
- ;; - https://issues.guix.gnu.org/63001
- ;; - https://issues.guix.gnu.org/63647
- ;; - https://issues.guix.gnu.org/69827
- (string-append "crypto/blake256/v" version)))))
+ (commit (go-version->git-ref version #:subdir "crypto/blake256"))))
(file-name (git-file-name name version))
(sha256
(base32 "1mjzlyz2a3516g46kv421nacjd7p4g9l8ih4i7xijvsi480s5pja"))
@@ -604,13 +598,7 @@ and AVX acceleration and zero allocations.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/decred/dcrd")
- (commit (go-version->git-ref
- ;; XXX: While waiting on consensus:
- ;; - https://issues.guix.gnu.org/52362
- ;; - https://issues.guix.gnu.org/63001
- ;; - https://issues.guix.gnu.org/63647
- ;; - https://issues.guix.gnu.org/69827
- (string-append "dcrec/secp256k1/v" version)))))
+ (commit (go-version->git-ref version #:subdir "dcrec/secp256k1"))))
(file-name (git-file-name name version))
(sha256
(base32 "19yqrrspm6n1x7wa1chqj0j95bc5w02ygddr06ajzf6x7i7q09q5"))
) #~(begin (use-modules (gnu build linux-boot) (gnu system file-systems) ((guix build utils) #:hide (delete)) (guix build bournish) ;add the 'bournish' meta-command (srfi srfi-1) ;for lvm-device-mapping (srfi srfi-26) ;; FIXME: The following modules are for ;; LUKS-DEVICE-MAPPING. We should instead propagate ;; this info via gexps. ((gnu build file-systems) #:select (find-partition-by-luks-uuid)) (rnrs bytevectors)) (with-output-to-port (%make-void-port "w") (lambda () (set-path-environment-variable "PATH" '("bin" "sbin") '#$helper-packages))) (parameterize ((current-warning-port (%make-void-port "w"))) (boot-system #:mounts (map spec->file-system '#$(map file-system->spec file-systems)) #:pre-mount (lambda () (and #$@device-mapping-commands #$@file-system-scan-commands)) #:linux-modules '#$linux-modules #:linux-module-directory '#$kodir #:keymap-file #+(and=> keyboard-layout keyboard-layout->console-keymap) #:qemu-guest-networking? #$qemu-networking? #:volatile-root? '#$volatile-root? #:on-error '#$on-error)))) #:name "raw-initrd")) (define* (file-system-packages file-systems #:key (volatile-root? #f)) "Return the list of statically-linked, stripped packages to check FILE-SYSTEMS." `(,@(if (find (lambda (fs) (string-prefix? "ext" (file-system-type fs))) file-systems) (list e2fsck/static) '()) ,@(if (find (lambda (fs) (string-suffix? "fat" (file-system-type fs))) file-systems) (list fatfsck/static) '()) ,@(if (find (file-system-type-predicate "bcachefs") file-systems) (list bcachefs/static) '()) ,@(if (find (file-system-type-predicate "btrfs") file-systems) (list btrfs-progs/static) '()) ,@(if (find (file-system-type-predicate "jfs") file-systems) (list jfs_fsck/static) '()) ,@(if (find (file-system-type-predicate "ntfs") file-systems) (list ntfsfix/static) '()) ,@(if (find (file-system-type-predicate "f2fs") file-systems) (list f2fs-fsck/static) '()) ,@(if (find (file-system-type-predicate "xfs") file-systems) (list xfs_repair/static) '()))) (define-syntax vhash ;TODO: factorize (syntax-rules (=>) "Build a vhash with the given key/value mappings." ((_) vlist-null) ((_ (key others ... => value) rest ...) (vhash-cons key value (vhash (others ... => value) rest ...))) ((_ (=> value) rest ...) (vhash rest ...)))) (define-syntax lookup-procedure (syntax-rules (else) "Return a procedure that lookups keys in the given dictionary." ((_ mapping ... (else default)) (let ((table (vhash mapping ...))) (lambda (key) (match (vhash-assoc key table) (#f default) ((key . value) value))))))) (define file-system-type-modules ;; Given a file system type, return the list of modules it needs. (lookup-procedure ("cifs" => '("md4" "ecb" "cifs")) ("9p" => '("9p" "9pnet_virtio")) ("bcachefs" => '("bcachefs")) ("btrfs" => '("btrfs")) ("iso9660" => '("isofs")) ("jfs" => '("jfs")) ("f2fs" => '("f2fs" "crc32_generic")) ("xfs" => '("xfs")) (else '()))) (define (file-system-modules file-systems) "Return the list of Linux modules needed to mount FILE-SYSTEMS." (append-map (compose file-system-type-modules file-system-type) file-systems)) (define* (default-initrd-modules #:optional (system (or (%current-target-system) (%current-system)))) "Return the list of modules included in the initrd by default." (define virtio-modules ;; Modules for Linux para-virtualized devices, for use in QEMU guests. '("virtio_pci" "virtio_balloon" "virtio_blk" "virtio_net" "virtio_console" "virtio-rng")) `("ahci" ;for SATA controllers "usb-storage" "uas" ;for the installation image etc. "usbhid" "hid-generic" "hid-apple" ;keyboards during early boot "dm-crypt" "xts" "serpent_generic" "wp512" ;for encrypted root partitions "nls_iso8859-1" ;for `mkfs.fat`, et.al ,@(if (string-match "^(x86_64|i[3-6]86)-" system) '("pata_acpi" "pata_atiixp" ;for ATA controllers "isci") ;for SAS controllers like Intel C602 '()) ,@virtio-modules)) (define-syntax %base-initrd-modules ;; This more closely matches our naming convention. (identifier-syntax (default-initrd-modules))) (define* (base-initrd file-systems #:key (linux linux-libre) (linux-modules '()) (mapped-devices '()) (keyboard-layout #f) qemu-networking? volatile-root? (extra-modules '()) ;deprecated (on-error 'debug)) "Return as a file-like object a generic initrd, with kernel modules taken from LINUX. FILE-SYSTEMS is a list of file-systems to be mounted by the initrd, possibly in addition to the root file system specified on the kernel command line via 'root'. MAPPED-DEVICES is a list of device mappings to realize before FILE-SYSTEMS are mounted. When true, KEYBOARD-LAYOUT is a record denoting the desired console keyboard layout. This is done before MAPPED-DEVICES are set up and before FILE-SYSTEMS are mounted such that, should the user need to enter a passphrase or use the REPL, this happens using the intended keyboard layout. QEMU-NETWORKING? and VOLATILE-ROOT? behaves as in raw-initrd. The initrd is automatically populated with all the kernel modules necessary for FILE-SYSTEMS and for the given options. Additional kernel modules can be listed in LINUX-MODULES. They will be added to the initrd, and loaded at boot time in the order in which they appear." (define linux-modules* ;; Modules added to the initrd and loaded from the initrd. `(,@linux-modules ,@(file-system-modules file-systems) ,@(if volatile-root? '("overlay") '()) ,@extra-modules)) (define helper-packages (append (file-system-packages file-systems #:volatile-root? volatile-root?) (if keyboard-layout (list loadkeys-static) '()))) (raw-initrd file-systems #:linux linux #:linux-modules linux-modules* #:mapped-devices mapped-devices #:helper-packages helper-packages #:keyboard-layout keyboard-layout #:qemu-networking? qemu-networking? #:volatile-root? volatile-root? #:on-error on-error)) ;;; linux-initrd.scm ends here