aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:03:16 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:03 +0000
commit6a85e9a269e8bc0331af2232cc929c53ff697433 (patch)
tree86d7ae0b47b8a25de31ccaa8081364098b8fa661 /gnu/packages/golang-crypto.scm
parentf4e1a37903152e13b8286cf353a2828e00420018 (diff)
downloadguix-6a85e9a269e8bc0331af2232cc929c53ff697433.tar.gz
guix-6a85e9a269e8bc0331af2232cc929c53ff697433.zip
gnu: go-github-com-marten-seemann-chacha20: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-marten-seemann-chacha20): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I25bc41e79e119f7a91510d5b7c55466ad7073a5c
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 4462eb6141..93123b547b 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;;
;;; This file is part of GNU Guix.
@@ -128,6 +129,28 @@ is standardized in RFC 7539.")
(description "PKI based identities for use in @command{go-libp2p}.")
(license license:expat))))
+(define-public go-github-com-marten-seemann-chacha20
+ (package
+ (name "go-github-com-marten-seemann-chacha20")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marten-seemann/chacha20")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x1j4cvbap45zk962qkjalc1h3axhzzdy9cdzhcjmprmm1ql4gjm"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/marten-seemann/chacha20"))
+ (home-page "https://github.com/marten-seemann/chacha20")
+ (synopsis "ChaCha20 in Go")
+ (description "This package is an external copy of the Go standard
+library's internal ChaCha20 package.")
+ (license license:bsd-3)))
+
(define-public go-github-com-multiformats-go-multihash
(let ((commit "97cdb562a04c6ef66d8ed40cd62f8fbcddd396d6")
(revision "0"))