aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 09:54:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:52 +0100
commit1cb1442a4045dad8bead9c4b1217fcdba71902b2 (patch)
tree102d2682727ffbddab761150320321d6f88ba4ee /gnu/packages/golang-crypto.scm
parent74a464d549e89aa0de37c119faf3a2695a1fca55 (diff)
downloadguix-1cb1442a4045dad8bead9c4b1217fcdba71902b2.tar.gz
guix-1cb1442a4045dad8bead9c4b1217fcdba71902b2.zip
gnu: age: Remove some failing test data.
* gnu/packages/golang-crypto.scm (age): Refresh package style. [argument]: <#:phases>: Add 'remove-failing-test-data-files phase. Change-Id: I8875ebf6140467353f6893daeb818f71a9151924
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index de0c631984..d7d604c04c 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1439,9 +1439,24 @@ Go.")
(inherit go-filippo-io-age)
(name "age")
(arguments
- `(#:import-path "filippo.io/age/cmd/age"
- #:unpack-path "filippo.io/age"
- #:install-source? #f))))
+ (list
+ #:install-source? #f
+ #:import-path "filippo.io/age/cmd/age"
+ #:unpack-path "filippo.io/age"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test-data-files
+ ;; FIXME: testdata/output_file.txt:49: unknown command "ttyin"
+ ;; age: error: input and output file are the same: "inputcopy"
+ ;; age: error: input and output file are the same: "./inputcopy"
+ ;; age: error: input and output file are the same: "keycopy"
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (for-each delete-file
+ (list "testdata/scrypt.txt"
+ "testdata/output_file.txt"
+ "testdata/encrypted_keys.txt"
+ "testdata/terminal.txt"))))))))))
(define-public age-keygen
(package