aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-20 16:37:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:59 +0100
commitd7f4f2c0538cdacf088f0108558c70656f96b4c2 (patch)
tree3c41708a40a7fbb2caf9479a03c33f928eebcf46 /gnu/packages/golang-check.scm
parentd43795cd208161495391104054e36abb94ea0a89 (diff)
downloadguix-d7f4f2c0538cdacf088f0108558c70656f96b4c2.tar.gz
guix-d7f4f2c0538cdacf088f0108558c70656f96b4c2.zip
gnu: go-github-com-stretchr-testify: Update to 1.9.0.
* gnu/packages/golang-check.scm (go-github-com-stretchr-testify): Update to 1.9.0. (go-github-com-stretchr-testify-next): Delete variable. (go-go-uber-org-goleak): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. * gnu/packages/golang-web.scm (go-github-com-quic-go-webtransport-go): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. * gnu/packages/golang-xyz.scm (go-github-com-masterminds-semver-v3, go-go-uber-org-dig, go-go-uber-org-fx, go-go-uber-org-zap): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. Change-Id: Ife39309254b5d89fcb61d84183771a4aab7e13db
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm21
1 files changed, 3 insertions, 18 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 4323a6c557..6baffb84d2 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -878,7 +878,7 @@ current goroutine's ID.")
(define-public go-github-com-stretchr-testify
(package
(name "go-github-com-stretchr-testify")
- (version "1.7.0")
+ (version "1.9.0")
(source
(origin
(method git-fetch)
@@ -888,7 +888,7 @@ current goroutine's ID.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ixgjsvafr3513pz3r6pmgk074s2dxkll0dadvl25gkf30rkmh10"))))
+ "12cnhk96h8b3ddlb7jfvwwavzc0j1c2iva92pszl9rv6r571ckzg"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/stretchr/testify"))
@@ -923,21 +923,6 @@ Features include:
(propagated-inputs
(list go-gopkg-in-yaml-v3)))))
-(define-public go-github-com-stretchr-testify-next
- (package
- (inherit go-github-com-stretchr-testify)
- (name "go-github-com-stretchr-testify")
- (version "1.9.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stretchr/testify")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "12cnhk96h8b3ddlb7jfvwwavzc0j1c2iva92pszl9rv6r571ckzg"))))))
-
(define-public go-github-com-tdewolff-test
(package
(name "go-github-com-tdewolff-test")
@@ -1280,7 +1265,7 @@ gracefully enhance standard library testing package and behaviors of the
(list
#:import-path "go.uber.org/goleak"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(home-page "https://pkg.go.dev/go.uber.org/goleak")
(synopsis "Goroutine leak detector")
(description