aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-08 13:05:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-08 13:05:56 +0100
commitd7d779a3eff9d7875d491e4180da665f6d2a1b86 (patch)
tree5dacbdb41a26fd52e1d8e3d92425f8917ff8a3cc /gnu/packages/golang-check.scm
parent7bf1d7aeaffba15c4f680f93ae88fbef25427252 (diff)
parent9a4cd495a428ddf90eeafcaea883af80350574d5 (diff)
downloadguix-d7d779a3eff9d7875d491e4180da665f6d2a1b86.tar.gz
guix-d7d779a3eff9d7875d491e4180da665f6d2a1b86.zip
Merge remote-tracking branch 'origin/go-team'
Change-Id: Ib66e48c4cb84e9e97ebcec334ab0b9f3dbfb1457
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm131
1 files changed, 62 insertions, 69 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 0822338943..287a514ace 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -286,7 +286,7 @@ workloads. This kind of profiling is also known as wall-clock profiling.")
(define-public go-github-com-frankban-quicktest
(package
(name "go-github-com-frankban-quicktest")
- (version "1.11.1")
+ (version "1.14.6")
(source
(origin
(method git-fetch)
@@ -295,13 +295,13 @@ workloads. This kind of profiling is also known as wall-clock profiling.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0b1b44b2hli2p969gqz30z8v9z6ahlklpqzi17nwk1lsjz9yv938"))))
+ (base32 "0gnh9v4cg39pw8y356299zhh5jmq2p4cf9945lfiqsjsk7h6ld70"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/frankban/quicktest"))
+ (list
+ #:import-path "github.com/frankban/quicktest"))
(propagated-inputs
- (list go-github-com-google-go-cmp-cmp go-github-com-kr-pretty))
+ (list go-github-com-google-go-cmp go-github-com-kr-pretty))
(home-page "https://github.com/frankban/quicktest")
(synopsis "Quick helpers for testing Go applications")
(description
@@ -312,7 +312,7 @@ tests.")
(define-public go-github-com-go-test-deep
(package
(name "go-github-com-go-test-deep")
- (version "1.0.8")
+ (version "1.1.1")
(source
(origin
(method git-fetch)
@@ -321,7 +321,7 @@ tests.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mmw2w3by7y24jjpjwmf2gfl08c65jihn3si9m0sswmagmdsk8q0"))))
+ (base32 "1vjzmd4gc3zr9hlpzhhq4g1d0k6rbhply10vdl49gvir4dzmzzrl"))))
(build-system go-build-system)
(arguments
(list #:import-path "github.com/go-test/deep"))
@@ -376,7 +376,7 @@ when comparing complex types like structures and maps.")
(arguments
'(#:import-path "github.com/google/go-cmdtest"))
(propagated-inputs
- (list go-github-com-google-renameio go-github-com-google-go-cmp-cmp))
+ (list go-github-com-google-renameio go-github-com-google-go-cmp))
(home-page "https://github.com/google/go-cmdtest")
(synopsis "Testing for your CLI")
(description
@@ -682,7 +682,7 @@ Gomega matcher library.")
(package
(inherit go-github-com-onsi-ginkgo)
(name "go-github-com-onsi-ginkgo-v2")
- (version "2.18.0")
+ (version "2.19.0")
(source
(origin
(method git-fetch)
@@ -691,7 +691,7 @@ Gomega matcher library.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1w5dldjjcz2kpyxml4zd9yah7galfpmhcpc2l4zc5pr3skpwpibv"))))
+ (base32 "0dwnkcysb5d9dyg8p84hhx5a3sj85g3bwgki1pgay4i8glz7xa7q"))))
(arguments
(list
#:import-path "github.com/onsi/ginkgo/v2"))
@@ -878,7 +878,7 @@ current goroutine's ID.")
(define-public go-github-com-stretchr-testify
(package
(name "go-github-com-stretchr-testify")
- (version "1.7.0")
+ (version "1.9.0")
(source
(origin
(method git-fetch)
@@ -888,7 +888,7 @@ current goroutine's ID.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ixgjsvafr3513pz3r6pmgk074s2dxkll0dadvl25gkf30rkmh10"))))
+ "12cnhk96h8b3ddlb7jfvwwavzc0j1c2iva92pszl9rv6r571ckzg"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/stretchr/testify"))
@@ -923,25 +923,10 @@ Features include:
(propagated-inputs
(list go-gopkg-in-yaml-v3)))))
-(define-public go-github-com-stretchr-testify-next
- (package
- (inherit go-github-com-stretchr-testify)
- (name "go-github-com-stretchr-testify")
- (version "1.9.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stretchr/testify")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "12cnhk96h8b3ddlb7jfvwwavzc0j1c2iva92pszl9rv6r571ckzg"))))))
-
(define-public go-github-com-tdewolff-test
(package
(name "go-github-com-tdewolff-test")
- (version "1.0.9")
+ (version "1.0.10")
(source
(origin
(method git-fetch)
@@ -950,11 +935,11 @@ Features include:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "10myz3zdkqmx37cvj507h7l2ncb0rq9shqvz9ggq1swijbsvazff"))))
+ (base32 "1ihlcnygwdgxq068b29d3n9n1gdbb2j03sc0al1qk5i5dkvgziyx"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/tdewolff/test"))
+ (list
+ #:import-path "github.com/tdewolff/test"))
(home-page "https://github.com/tdewolff/test")
(synopsis "Go test helper functions")
(description
@@ -1011,7 +996,7 @@ functions for writing tests in Go.")
(arguments
'(#:import-path "github.com/smartystreets/goconvey"))
(propagated-inputs
- (list go-github.com-jtolds-gls go-github.com-smartystreets-assertions))
+ (list go-github-com-jtolds-gls go-github.com-smartystreets-assertions))
(home-page "https://github.com/smartystreets/goconvey")
(synopsis "Go testing tool with both a web and terminal user interface")
(description "GoConvey is a testing tool for Go. It integrates with go
@@ -1051,7 +1036,7 @@ under test) much simpler.")
(define-public go-go-etcd-io-gofail
(package
(name "go-go-etcd-io-gofail")
- (version "0.1.0")
+ (version "0.2.0")
(source
(origin
(method git-fetch)
@@ -1060,7 +1045,7 @@ under test) much simpler.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0jh0qjgfb2irshwj7an3lj0w9bv6c5gbnkdhisgpdr7x7hk682m1"))))
+ (base32 "0wxjaq1v5w0wjyv84af5cazrmv369i1416ar0dx8r9ag1szcfvpc"))))
(build-system go-build-system)
(arguments
(list
@@ -1080,32 +1065,34 @@ under test) much simpler.")
(license license:asl2.0)))
(define-public go-golang-org-sql-mock
- (let ((commit "e98392b8111b45f8126e00af035a0dd95dc12e8b")
- (version "1.3.3")
- (revision "1"))
- (package
- (name "go-golang-org-sql-mock")
- (version (git-version version revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/DATA-DOG/go-sqlmock")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "033vv29g2wf6fd757ajfmha30bqin3b07377037zkl051mk6mghs"))
- (modules '((guix build utils)))
- (snippet '(delete-file-recursively "examples"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/DATA-DOG/go-sqlmock"))
- (synopsis "Mock library implementing @code{sql/driver}")
- (description "This library simulates SQL-driver behavior in tests
-without requiring a real database connection.")
- (home-page "https://github.com/DATA-DOG/go-sqlmock")
- (license license:expat))))
+ (package
+ (name "go-golang-org-sql-mock")
+ (version "1.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DATA-DOG/go-sqlmock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vpvdx9hwmx9gm27aq5r5219xpaxz0gy4q1iqskk4saz05bspn0f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/DATA-DOG/go-sqlmock"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
+ (home-page "https://github.com/DATA-DOG/go-sqlmock")
+ (synopsis "Mock library implementing @code{sql/driver}")
+ (description
+ "This library simulates SQL-driver behavior in tests without requiring a
+real database connection.")
+ (license license:expat)))
(define-public go-golang-org-x-lint
(let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
@@ -1264,7 +1251,7 @@ gracefully enhance standard library testing package and behaviors of the
(define-public go-go-uber-org-goleak
(package
(name "go-go-uber-org-goleak")
- (version "1.2.0")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -1273,14 +1260,13 @@ gracefully enhance standard library testing package and behaviors of the
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1lpqw7ygffak8qki9i4vw8b99l25l8jrw8iwcplqsclk6fzkl24p"))))
+ (base32 "14rvkxh3znp9jzbdjqdkrly3zfg3rmhgg5845biqqrq17w8jvv5s"))))
(build-system go-build-system)
(arguments
(list
#:import-path "go.uber.org/goleak"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(home-page "https://pkg.go.dev/go.uber.org/goleak")
(synopsis "Goroutine leak detector")
(description
@@ -1375,16 +1361,23 @@ advanced Go linter.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.18
- #:import-path "pgregory.net/rapid"))
+ #:import-path "pgregory.net/rapid"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ ;; Remove test file failing on go-1.21, see
+ ;; <https://github.com/flyingmutant/rapid/issues/68>.
+ (delete-file "strings_example_test.go")))))))
(home-page "https://pgregory.net/rapid/")
(synopsis "Go property-based testing library")
(description
"@code{Rapid} is a Go library for property-based testing.
-Rapid checks that properties you define hold for a large number of automatically
-generated test cases. If a failure is found, rapid automatically minimizes the
-failing test case before presenting it.
+Rapid checks that properties you define hold for a large number of
+automatically generated test cases. If a failure is found, rapid
+automatically minimizes the failing test case before presenting it.
Features:
@itemize