aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 11:01:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:55 +0000
commitc7e9c98ef63549b35021d17260f7d8bd5a91f494 (patch)
treea1589702d239d0442af9e66837e61f403d349da9 /gnu/packages/golang-check.scm
parentd19a9e553acf6da47575a5f6bd177d478a893f71 (diff)
downloadguix-c7e9c98ef63549b35021d17260f7d8bd5a91f494.tar.gz
guix-c7e9c98ef63549b35021d17260f7d8bd5a91f494.zip
gnu: Add go-github-com-matryer-is.
* gnu/packages/golang-check.scm (go-github-com-matryer-is): New variable. Change-Id: I215a7291620b7c2fc34ae759801466856e829263
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 958b35f63d..3e33cdb976 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -733,6 +733,30 @@ integrates with the default test runner, so you can use it with the standard
output capturing, mocking, and much more.")
(license license:expat)))
+(define-public go-github-com-matryer-is
+ (package
+ (name "go-github-com-matryer-is")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/matryer/is")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04wgh8j2n19a5a4p8jjnya6yl5dm07kbbcz8gq6gj980bd9fk1ir"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/matryer/is"))
+ (home-page "https://github.com/matryer/is")
+ (synopsis "Lightweight testing mini-framework for Golang")
+ (description
+ "Package is provides a lightweight extension to the standard library's
+testing capabilities.")
+ (license license:expat)))
+
(define-public go-github-com-onsi-ginkgo
(package
(name "go-github-com-onsi-ginkgo")