aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-14 22:55:00 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-22 19:00:18 +0300
commit8398642ec371a8c68b8e42a1b263ccf5ca5e3351 (patch)
tree273692ab029fd470fb51f8649e7ad2462805366d /gnu/packages/golang-check.scm
parent12b606f276e084c1a88795ff411bd22cf9ab4a92 (diff)
downloadguix-8398642ec371a8c68b8e42a1b263ccf5ca5e3351.tar.gz
guix-8398642ec371a8c68b8e42a1b263ccf5ca5e3351.zip
gnu: Add go-github-com-zeebo-assert.
* gnu/packages/golang-crypto.scm (go-github-com-zeebo-assert): New variable. Change-Id: I03a752d42e016acd416087d4426864384ffc8a05 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 3e33cdb976..7e5abf9f09 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2024 Greg Hogan <code@greghogan.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1402,6 +1403,30 @@ gracefully enhance standard library testing package and behaviors of the
@command{go test} command.")
(license license:expat)))
+(define-public go-github-com-zeebo-assert
+ (package
+ (name "go-github-com-zeebo-assert")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zeebo/assert")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xfklg04ic4xl5q7xy913jzvn2v9bxmrsnm4lyjqznninysgs9xb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zeebo/assert"))
+ (home-page "https://github.com/zeebo/assert")
+ (synopsis "High-level assertions for tests")
+ (description
+ "@code{assert} is a testing library that provides high-level assertions API
+based on Go @code{testing} library procedures.")
+ (license license:cc0)))
+
(define-public go-go-uber-org-goleak
(package
(name "go-go-uber-org-goleak")