aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 14:51:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:52 +0100
commit39b908a389fcea3660c628920f4ba5d6510dbe64 (patch)
tree215922b147fb5176ef09d5e7b5a23e56870895ba /gnu/packages/golang-check.scm
parent59b22fbe0ed67361702dfd65ad6ec05b284c24bb (diff)
downloadguix-39b908a389fcea3660c628920f4ba5d6510dbe64.tar.gz
guix-39b908a389fcea3660c628920f4ba5d6510dbe64.zip
gnu: go-honnef-co-go-tools: Enable tests.
* gnu/packages/golang-check.scm (go-honnef-co-go-tools): Apply new package style. [arguments]: <#:phases>: Use custom 'check phase. Change-Id: Idecf23f79ea554a84bce57a4dd356dde5f0b300a
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 53c876ae00..b3c5286a72 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1336,11 +1336,17 @@ built-in @code{testing} package, but can be used in other contexts too.")
"1n58skq2a0vhsgdfdkyqi00d3vv13kiw9b4mxx6xfyb6ysrdy7d1"))))
(build-system go-build-system)
(arguments
- `(#:import-path "honnef.co/go/tools"
- #:tests? #f
- ;; Source-only package
- #:phases (modify-phases %standard-phases
- (delete 'build))))
+ (list
+ #:import-path "honnef.co/go/tools"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(propagated-inputs
(list go-github-com-burntsushi-toml
go-golang-org-x-exp-typeparams