aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-07 14:56:42 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-14 14:09:21 +0200
commit6a180f6f36c35461016a57f265305ca08123fd80 (patch)
tree9312c67f5f8eab47f3fc52fb31d0a3091b392066 /gnu/packages/gnome.scm
parent9349655820110afb5ea8e20e54369f984b40cb79 (diff)
downloadguix-6a180f6f36c35461016a57f265305ca08123fd80.tar.gz
guix-6a180f6f36c35461016a57f265305ca08123fd80.zip
gnu: Add libgweather.
* gnu/packages/gnome.scm (libgweather): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 217b1350b9..ec2508dfd5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -31,6 +31,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
@@ -2078,3 +2079,50 @@ listening to device events and querying history and statistics. Any
application or service on the system can access the org.freedesktop.UPower
service via the system message bus.")
(license license:gpl2+)))
+
+(define-public libgweather
+ (package
+ (name "libgweather")
+ (version "3.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0x1z6wv7hdw2ivlkifcbd940zyrnvqvc4zh2drgvd2r6jmd7bjza"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; The tests want to write to $HOME/.cache/geocode-glib, which doesn't
+ ;; work for the builder. Punt.
+ #:tests? #f
+ #:make-flags '("CC=gcc") ; for g-ir-scanner
+ #:configure-flags
+ `(;; No introspection for now, as it wants to install to
+ ;; gobject-introspection's own directory and I don't know how to easily
+ ;; override this.
+ "--enable-introspection=no"
+ ,(string-append "--with-zoneinfo-dir="
+ (assoc-ref %build-inputs "tzdata")
+ "/share/zoneinfo"))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-mkenums
+ ("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (propagated-inputs
+ ;; gweather-3.0.pc refers to GTK+, GDK-Pixbuf, GLib/GObject, libxml, and
+ ;; libsoup.
+ `(("gtk+" ,gtk+)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("libxml2" ,libxml2)
+ ("libsoup" ,libsoup)))
+ (inputs
+ `(("tzdata" ,tzdata)
+ ("geocode-glib" ,geocode-glib)))
+ (home-page "https://wiki.gnome.org/action/show/Projects/LibGWeather")
+ (synopsis "Location, time zone, and weather library for GNOME")
+ (description
+ "libgweather is a library to access weather information from online
+services for numerous locations.")
+ (license license:gpl2+)))