aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-09 12:22:14 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-09 12:22:14 +0200
commit94ca5b4357af8f8921f0cb0873a7cf316f13aa69 (patch)
tree6ef30120737f26f298f7f17d86597b0b729517e0 /gnu/packages/gnome-xyz.scm
parent6750c114e3e988249f4069d0180316c6d0192350 (diff)
parentdb61bdd7f52270a35bd0a3a88650d98276dab20b (diff)
downloadguix-94ca5b4357af8f8921f0cb0873a7cf316f13aa69.tar.gz
guix-94ca5b4357af8f8921f0cb0873a7cf316f13aa69.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm45
1 files changed, 41 insertions, 4 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a1701aaa77..8b5dc3030e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -240,6 +240,39 @@ simple and consistent.")
and a few extra features.")
(license license:gpl3)))
+(define-public qogir-icon-theme
+ (package
+ (name "qogir-icon-theme")
+ (version "2023.06.05")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vinceliuice/Qogir-icon-theme")
+ (commit (string-replace-substring version "." "-"))))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet '(substitute* "install.sh"
+ (("gtk-update-icon-cache") "true")))
+ (sha256
+ (base32
+ "1kn8b9zdamxbfbs7b9qpx53hmjw2l40sxpjw93axb1dqy81yc8da"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (let* ((dest (string-append #$output "/share/icons"))
+ (flags (list "--theme" "all"
+ "--color" "all"
+ "--dest" dest)))
+ (mkdir-p dest)
+ (apply invoke "bash" "install.sh" flags)))))))
+ (home-page "https://www.pling.com/p/1296407/")
+ (synopsis "Flat colorful design icon theme")
+ (description "This package provides a flat colorful design icon theme.")
+ (license license:gpl3)))
+
(define-public flat-remix-icon-theme
(package
(name "flat-remix-icon-theme")
@@ -451,7 +484,7 @@ takes advantage of modern hardware using OpenGL.")
(define-public portfolio
(package
(name "portfolio")
- (version "0.9.14")
+ (version "1.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -460,7 +493,7 @@ takes advantage of modern hardware using OpenGL.")
(file-name (git-file-name name version))
(sha256
(base32
- "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ "1ai9mx801m5lngkljg42vrpvhbvc3071sp4jypsvbzw55hxnn5ba"))))
(arguments
(list #:glib-or-gtk? #t
#:imported-modules `(,@%meson-build-system-modules
@@ -475,6 +508,10 @@ takes advantage of modern hardware using OpenGL.")
(with-directory-excursion (string-append #$output
"/bin")
(symlink "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "build-aux/meson/postinstall.py"
+ (("gtk-update-icon-cache") "true"))))
(add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs
@@ -486,12 +523,12 @@ takes advantage of modern hardware using OpenGL.")
`("GI_TYPELIB_PATH" =
(,(getenv "GI_TYPELIB_PATH")))))))))
(build-system meson-build-system)
- (inputs (list bash-minimal python-pygobject gtk+ libhandy))
+ (inputs (list bash-minimal python-pygobject gtk libadwaita))
(native-inputs
(list desktop-file-utils
gettext-minimal
`(,glib "bin")
- `(,gtk+ "bin")
+ pkg-config
python))
(home-page "https://github.com/tchx84/Portfolio")
(synopsis "Minimalist file manager for Linux mobile devices")