aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-20 16:56:53 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:16 +0200
commit45d66ce8e995761dcde73c7ae437e00ab91ab8d7 (patch)
treea20d8970342df665bba90079a6f7c67039f86d82 /gnu/packages/ghostscript.scm
parent9ebaf6518a4f4fb556adec05a4ac6c1c92f6076d (diff)
downloadguix-45d66ce8e995761dcde73c7ae437e00ab91ab8d7.tar.gz
guix-45d66ce8e995761dcde73c7ae437e00ab91ab8d7.zip
gnu: ghostscript: Ungraft.
* gnu/packages/ghostscript.scm (ghostscript)[source]: Fold extra patches. [replacement]: Remove. (ghostscript/fixed): Remove. Change-Id: I116d49c308223207382337395a1c6cba83508a0e
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 19389bed46..e95069cdd1 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2013, 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015-2017, 2019, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
@@ -161,7 +161,6 @@ printing, and psresize, for adjusting page sizes.")
(package
(name "ghostscript")
(version "9.56.1")
- (replacement ghostscript/fixed)
(source
(origin
(method url-fetch)
@@ -174,7 +173,9 @@ printing, and psresize, for adjusting page sizes.")
"1r5qash65m6ignki6z72q4rlai9ka99xrxnmqd19n02has00cd6l"))
(patches (search-patches "ghostscript-no-header-creationdate.patch"
"ghostscript-no-header-id.patch"
- "ghostscript-no-header-uuid.patch"))
+ "ghostscript-no-header-uuid.patch"
+ "ghostscript-CVE-2023-36664.patch"
+ "ghostscript-CVE-2023-36664-fixup.patch"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries. The bundled OpenJPEG is a patched fork so
@@ -293,12 +294,6 @@ output file formats and printers.")
(home-page "https://www.ghostscript.com/")
(license license:agpl3+)))
-(define ghostscript/fixed
- (package-with-patches
- ghostscript
- (search-patches "ghostscript-CVE-2023-36664.patch"
- "ghostscript-CVE-2023-36664-fixup.patch")))
-
(define-public ghostscript/x
(package/inherit ghostscript
(name (string-append (package-name ghostscript) "-with-x"))