aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-12-17 11:42:58 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-12-20 17:50:26 +0100
commitf912be4c12ec4c3200dccca642c7021aa872d3c2 (patch)
tree716508429b197976fa99c89ea840e05c1e5fc15c /gnu/packages/geo.scm
parent9c5c432f407d6717c85c25a09910d600a69d38da (diff)
downloadguix-f912be4c12ec4c3200dccca642c7021aa872d3c2.tar.gz
guix-f912be4c12ec4c3200dccca642c7021aa872d3c2.zip
gnu: python-cartopy: Update to 0.21.0.
* gnu/packages/geo.scm (python-cartopy): Update to 0.21.0. [inputs]: Remove proj. [native-inputs]: Add python-pytest-mpl. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b157678eba..897d5ecee6 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1178,13 +1178,13 @@ utilities for data translation and processing.")
(package
(name "python-cartopy")
;; This is a post-release fix that adds build_ext to setup.py.
- (version "0.20.3")
+ (version "0.21.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cartopy" version))
(sha256
- (base32 "01lhnkhw22jp6hnrs5qvgkq4fqcni2sx7ydiyv8w8xxx5wpglq0d"))))
+ (base32 "0hnfs75dcnz12ximah5xn9566r8zz189lxikmj4lrs9jl4l3l7ff"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1207,13 +1207,12 @@ utilities for data translation and processing.")
python-scipy
python-shapely))
(inputs
- (list geos
- ;; cartopy's setup.py looks for the proj executable.
- ;; Not sure if it actually makes use of it since it
- ;; probably uses proj only through pyproj.
- proj))
+ (list geos))
(native-inputs
- (list python-cython python-flufl-lock python-pytest))
+ (list python-cython
+ python-flufl-lock
+ python-pytest
+ python-pytest-mpl))
(home-page "https://scitools.org.uk/cartopy/docs/latest/")
(synopsis "Cartographic library for visualisation")
(description