aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-04-02 17:45:47 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-04-12 10:50:56 +0200
commit3171ee7003682622e3c0db67c08e302090ca0f6f (patch)
tree17e47bff3af310429ddaf6a46c2dea92de76d2a1 /gnu/packages/geo.scm
parent27b58a799c1350f022984af60971339952c7d96c (diff)
downloadguix-3171ee7003682622e3c0db67c08e302090ca0f6f.tar.gz
guix-3171ee7003682622e3c0db67c08e302090ca0f6f.zip
gnu: python-cartopy: Disable some tests.
Some tests fail with proj 9.2.0. * gnu/packages/geo.scm (python-cartopy)[arguments]: Update 'check' phase. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8c93f86dd2..344ffae8fb 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1183,8 +1183,17 @@ utilities for data translation and processing.")
(invoke "python" "-m" "pytest" "--pyargs" "cartopy"
;; These tests require online data.
"-m" "not natural_earth and not network"
- ;; This one too but it's not marked as such.
- "-k" "not test_gridliner_labels_bbox_style")))))))
+ "-k"
+ (string-append
+ ;; This one too but it's not marked as such.
+ "not test_gridliner_labels_bbox_style"
+ ;; Those tests fail with proj 9.2.0
+ ;; https://github.com/SciTools/cartopy/issues/2145
+ " and not test_epsg"
+ " and not test_default"
+ " and not test_eccentric_globe"
+ " and not test_ellipsoid_transform"
+ " and not test_eccentric_globe"))))))))
(propagated-inputs
(list python-matplotlib
python-numpy