aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 21:41:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:34 +0300
commit32906b0933bd225199b578106802962cf9126d16 (patch)
tree39ef10ee267878a9bae8f7d09d18c2c7415e142b /gnu/packages/gd.scm
parent8a1716fe3f69462eb0d436ff29bb8c17e799b0f5 (diff)
downloadguix-32906b0933bd225199b578106802962cf9126d16.tar.gz
guix-32906b0933bd225199b578106802962cf9126d16.zip
gnu: gd: Update to 2.2.5.
* gnu/packages/gd.scm (gd): Update to 2.2.5. [replacement]: Remove field. [sources]: Remove two patches. (gd-2.2.5): Remove variable. * gnu/packages/patches/gd-fix-gd2-read-test.patch, gnu/packages/patches/gd-php-73968-Fix-109-XBM-reading.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm27
1 files changed, 4 insertions, 23 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 169f040ee4..f9864d7784 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -38,11 +38,10 @@
(define-public gd
(package
(name "gd")
- (replacement gd-2.2.5)
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.2.4")
+ (version "2.2.5")
(source (origin
(method url-fetch)
(uri (string-append
@@ -50,11 +49,9 @@
version "/libgd-" version ".tar.xz"))
(sha256
(base32
- "1rp4v7n1dq38b92kl7gkvpvqqkw7nvdfnz6d5kip5klkxfki6zqk"))
- (patches (search-patches "gd-fix-gd2-read-test.patch"
- "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"
- "gd-php-73968-Fix-109-XBM-reading.patch"))))
+ "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
+ (patches (search-patches "gd-fix-tests-on-i686.patch"
+ "gd-freetype-test-failure.patch"))))
(build-system gnu-build-system)
(arguments
;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
@@ -93,22 +90,6 @@ most common applications of GD involve website development.")
"See COPYING file in the distribution."))
(properties '((cpe-name . "libgd")))))
-;; For CVE-2017-6362 and CVE-2017-7890.
-(define-public gd-2.2.5
- (package
- (inherit gd)
- (version "2.2.5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/libgd/libgd/releases/download/gd-"
- version "/libgd-" version ".tar.xz"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"))
- (sha256
- (base32
- "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))))))
-
(define-public perl-gd
(package
(name "perl-gd")