aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-06-27 10:33:08 +0200
committerJohn Darrington <jmd@gnu.org>2014-06-27 17:53:40 +0200
commitdff624230a47a25d64ab5bd10378ca0e7053bd33 (patch)
tree3e676332c0001d20b8ddcf82eba94c9ff098d96c /gnu/packages/games.scm
parent51d3dcea42f570d3d44af701e0c09ef1d1bfcea0 (diff)
downloadguix-dff624230a47a25d64ab5bd10378ca0e7053bd33.tar.gz
guix-dff624230a47a25d64ab5bd10378ca0e7053bd33.zip
gnu: Add talkfilters.
* gnu/packages/games.scm (talkfilters): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 22412e4093..8a2b2df022 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -208,3 +208,23 @@ in the other direction. Multiple such commands are necessary to reach the
level's exit. The game is presented in a 2D side view.")
;; Some source files are under bsd-3 and gpl2+ licenses.
(license gpl3+)))
+
+(define-public talkfilters
+ (package
+ (name "talkfilters")
+ (version "2.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.hyperrealm.com/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19nc5vq4bnkjvhk8srqddzhcs93jyvpm9r6lzjzwc1mgf08yg0a6"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/talkfilters")
+ (synopsis "Convert English text to humorous dialects")
+ (description "The GNU Talk Filters are programs that convert English text
+into stereotyped or otherwise humorous dialects. The filters are provided as
+a C library, so they can easily be integrated into other programs.")
+ (license gpl2+)))
+