aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2023-05-07 17:43:33 -0700
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-09 07:31:36 +0200
commit8306d3e52902c0d9cffd9a79b379c917c8cf49be (patch)
tree9d5d6fc720e4d9e7303ac145581b6c78ff8d8674 /gnu/packages/games.scm
parent4c610d2b2e700a8aca6d5aba344e0dabad386467 (diff)
downloadguix-8306d3e52902c0d9cffd9a79b379c917c8cf49be.tar.gz
guix-8306d3e52902c0d9cffd9a79b379c917c8cf49be.zip
gnu: Add vcmi.
* gnu/packages/games.scm (vcmi): New variable. * gnu/packages/patches/vcmi-disable-privacy-breach.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5dde152041..fdd3a0e21e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -203,6 +203,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages squirrel)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages tbb)
#:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
@@ -11307,6 +11308,54 @@ Magic II (aka HOMM2) game engine. It requires assets and game resources to
play; it will look for them at @file{~/.local/share/fheroes2} folder.")
(license license:gpl2)))
+(define-public vcmi
+ (package
+ (name "vcmi")
+ (version "1.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vcmi/vcmi")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f3fk1fc2wb7f2j4pxz89dzr8zjnrdh435mijia483a3bq59w7pk"))
+ (patches (search-patches "vcmi-disable-privacy-breach.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DFORCE_BUNDLED_FL=OFF")
+ ;; Test suites do not seem well supported upstream and are disabled by default.
+ ;; Pass -DENABLE_TEST to configure to enable.
+ #:tests? #f))
+ (native-inputs
+ (list boost
+ ffmpeg
+ fuzzylite
+ ;; googletest ; needed for tests, but tests are disabled
+ libxkbcommon
+ luajit
+ minizip
+ pkg-config
+ python
+ ;; XXX: Build currently fails with qtbase-6 and qttools-6
+ qtbase-5
+ qttools-5
+ sdl2
+ sdl2-mixer
+ sdl2-image
+ sdl2-ttf
+ tbb
+ vulkan-headers
+ zlib))
+ (home-page "https://vcmi.eu/")
+ (synopsis "Turn-based strategy game engine")
+ (description
+ "@code{vcmi} is an implementation of the Heroes of Might and
+Magic III game engine. It requires assets and game resources to
+play; it will look for them at @file{~/.local/share/vcmi} folder.")
+ (license license:gpl2)))
+
(define-public apricots
(package
(name "apricots")