aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
2691864533aa1d557838bc842aa88b2f9daa37d4&id2=675f324e12eb48323c4e2b879629f938bcf45397'>diff)
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-18 17:16:04 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-11-18 21:09:43 +02002021-05-09Merge branch 'master' into core-updates...Marius Bakke
2021-05-07gnu: mame: Fix build....Nicolas Goaziou
2021-05-07gnu: mame: Update to 0.231....Nicolas Goaziou
downloadguix-2691864533aa1d557838bc842aa88b2f9daa37d4.tar.gz
guix-2691864533aa1d557838bc842aa88b2f9daa37d4.zip
gnu: irrlicht: Fix build.
* gnu/packages/games.scm (irrlicht) [phase remove-<sys/systctl.h>]: <sys/sysctl.h> has been removed from glibc, and it is not used, so remove it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e01ad3c8d2..c80335a1ea 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3568,6 +3568,10 @@ are primarily in English, however some in other languages are provided.")
;; The actual source is buried a few directories deep.
(chdir "source/Irrlicht/")
#t))
+ (add-after 'chdir-to-source 'remove-<sys/sysctl.h>
+ (lambda _
+ (substitute* "COSOperator.cpp"
+ (("#include <sys/sysctl.h>") ""))))
(add-after 'chdir-to-source 'fix-build-env
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))