aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-09-23 14:53:44 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-09-23 14:53:44 +0200
commit1828958db52d0019a7f3d763b07e64f78afa2cbf (patch)
tree8bdff27c5b3dc088d923e91a14a38f6a6b9fa661 /gnu/packages/games.scm
parent7e463dd16b7e273011f0beafa57a89fa2d525f8b (diff)
parent23744435613aa040beacc61a0825cc72280da80a (diff)
downloadguix-1828958db52d0019a7f3d763b07e64f78afa2cbf.tar.gz
guix-1828958db52d0019a7f3d763b07e64f78afa2cbf.zip
Merge branch 'wip-lisp' into staging
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm33
1 files changed, 15 insertions, 18 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1cd0df0dd0..ac5d08b79b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016, 2017 Rodger Fox <thylakoid@openmailbox.org>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -385,15 +385,17 @@ The game includes a built-in editor so you can design and share your own maps.")
(define-public armagetronad
(package
(name "armagetronad")
- (version "0.2.8.3.5")
+ (version "0.2.9.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/armagetronad/stable/"
- version "/armagetronad-" version ".src.tar.gz"))
+ version "/armagetronad-" version ".tbz"))
(sha256
(base32
- "1z266haq22n5b0733h7qsg1rpzhz8lvm82f7wd06r008iiar7jdl"))))
+ "19rfhlg4gp0r7k1j8v4iw20325ciy156nmzax4xikmw22c6nmxcz"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("libxml2" ,libxml2)
("sdl" ,sdl)
@@ -1811,15 +1813,16 @@ Every puzzle has a complete solution, although there may be more than one.")
(define-public retux
(package
(name "retux")
- (version "1.3.6")
+ (version "1.4")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/retux/"
+ (uri (string-append "https://github.com/retux-game/retux/"
+ "releases/download/v"
(version-major+minor version) "/retux-"
version "-src.tar.gz"))
(sha256
(base32
- "01bidh4zisjp3nc436x0g85v60dvwb3ig37i7y01sa71j8fm4fmb"))))
+ "1hxy1pvlxhk0ci3wh2i3mmr82faqdjnnxsiwwr5gcr93nfnw9w5f"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -1831,28 +1834,22 @@ Every puzzle has a complete solution, although there may be more than one.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
- (data (string-append out "/share/retux"))
- (doc (string-append out "/share/doc/retux")))
+ (data (string-append out "/share/retux")))
(mkdir-p bin)
(substitute* "retux.py"
;; Use the correct data directory.
(("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
- (string-append "\"" data "\","))
- ;; Use Python 3 so the patch-shebangs phase works properly.
- ((".*python2.*") "#!/usr/bin/python3"))
+ (string-append "\"" data "\",")))
(copy-file "retux.py" (string-append bin "/retux"))
-
(copy-recursively "data" data)
-
- (install-file "COPYING" doc)
#t))))))
(inputs
`(("python-sge-pygame" ,python-sge-pygame)
("python-six" ,python-six)
("python-xsge" ,python-xsge)))
- (home-page "http://retux.nongnu.org")
+ (home-page "https://retux-game.github.io/")
(synopsis "Action platformer game")
(description
"ReTux is an action platformer loosely inspired by the Mario games,
@@ -4788,7 +4785,7 @@ of war. Widelands also offers an Artificial Intelligence to challenge you.")
(define-public starfighter
(package
(name "starfighter")
- (version "2.3.1")
+ (version "2.3.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4797,7 +4794,7 @@ of war. Widelands also offers an Artificial Intelligence to challenge you.")
version "-src.tar.gz"))
(sha256
(base32
- "13396hvsj4cswlrw52kwqn37dadxps00vhr0hrqgm87fl4ih5yyx"))))
+ "1nvi277cazsw36b6nhd5nmk0cjvm71rlxasy24mf18j7fsvq9vp8"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))