aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-12-31 14:17:33 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-07 10:06:42 +0100
commit11136fb0ad90937516ce0421a352e3a4513fca3b (patch)
treea6d357de8c5a663df8409543c670bb0c244cf79c /gnu/packages/games.scm
parent25bcf4eda05b501758b11a53823867dc500ac7d1 (diff)
downloadguix-11136fb0ad90937516ce0421a352e3a4513fca3b.tar.gz
guix-11136fb0ad90937516ce0421a352e3a4513fca3b.zip
gnu: Add morris.
* gnu/packages/games.scm (morris): New variable. Change-Id: I35158d1f5cfd5f7267dcb8295d8102e2dd3f575c Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4a2b2fd832..4883d33374 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10446,6 +10446,31 @@ sunfish, but is written in C rather than Python. It also has TUI tools for
using any UCI engine and also to connect UCI engines to Lichess.")
(license license:agpl3+))))
+(define-public morris
+ (package
+ (name "morris")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/farindk/morris")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kkcnpkzgybm7rqg7nafd7sqd5m4alns6l4j5zcf3p41jdc9s3iv"))))
+ (build-system glib-or-gtk-build-system)
+ (inputs (list automake autoconf pkg-config intltool
+ gnu-gettext libtool glib gtk+-2 boost))
+ (arguments `(#:tests? #f))
+ (home-page "http://nine-mens-morris.net/downloads.html")
+ (synopsis "Morris is an implementation of the board game Nine Men's Morris")
+ (description "Morris is an implementation of the board game Nine Men's Morris.
+It supports not only the standard game, but also several rule-variants and different
+board layouts. You can play against the computer, or simply use the program to
+present the board, but play against another human opponent.")
+ (license license:gpl3)))
+
(define-public barrage
(package
(name "barrage")