aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-07-14 11:08:31 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-14 11:08:31 -0400
commit09e73683a2c303016fa57bf5d84a8e997d4c0a30 (patch)
treea00e38a0b98f984916849882204e915c2cdfe65d /gnu/packages/games.scm
parent49b0a5ee5f908d8efa8e792f8635f723fd1d26ed (diff)
downloadguix-09e73683a2c303016fa57bf5d84a8e997d4c0a30.tar.gz
guix-09e73683a2c303016fa57bf5d84a8e997d4c0a30.zip
gnu: godot: Update to 4.1. Rename godot@3 to godot-lts.
* gnu/packages/game-development.scm (godot): Update to 4.1. [source]: Update snippet: remove embree and enet; add amd-fsr, astcenc, basis_universal, brotli, linuxbsd_headers, etcpak, meshoptimizer, msdfgen, noise, openxr, rvo2, spirv-reflect, thorvg, volk, vulkan. [arguments]: Remove #:scons. Update #:scons-flags to unbundle more libraries. [phases]: Remove 'build-headless phase (headless is no longer has a separate build). Add 'fix-dl-open-paths and 'unbundle-xkbcommon phases. In 'install phase, remove headless output. Update 'wrap phase to remove eudev. [outputs]: Remove headless. [inputs]: Add dbus, embree, enet, fontconfig, glslang, libpng, harfbuzz, icu4c, libxkbcommon, openxr, speech-dispatcher, vulkan-loader, zlib. Remove bullet. Rename freetype to freetype-with-brotli. (godot-lts): New variable. godot@3 is the LTS release. * gnu/packages/games.scm (superstarfighter)[native-inputs]: Use it. [inputs]: Use it.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fdd3a0e21e..f0d29f2367 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2826,9 +2826,9 @@ runnable=true
#:categories '("Game" "ArcadeGame")))
#t)))))
(native-inputs
- `(("godot-headless" ,godot "headless")))
+ `(("godot-headless" ,godot-lts "headless")))
(inputs
- (list godot))
+ (list godot-lts))
(home-page "https://notapixel.itch.io/superstarfighter")
(synopsis "Fast-paced local multiplayer arcade game")
(description "In SuperStarfighter, up to four local players compete in a