aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-01 17:20:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-01 19:08:12 -0400
commitbd638a8ad6140db87851a86faae89e736e148f3d (patch)
treef3bdfdd2cba0ddd192cba02c59a5f9554a9fde2c /gnu/packages/game-development.scm
parentdb5fa0cda7846c32bf37d24c3cf2b11a62778aac (diff)
downloadguix-bd638a8ad6140db87851a86faae89e736e148f3d.tar.gz
guix-bd638a8ad6140db87851a86faae89e736e148f3d.zip
gnu: Delete mono and dependent packages.
Fixes <https://issues.guix.gnu.org/55026>. * gnu/packages/mono.scm: Delete file. * gnu/packages/patches/mono-mdoc-timestamping.patch: Likewise. * gnu/local.mk (GNU_SYSTEM_MODULES): De-register module file. (dist_patch_DATA): Re-register patch file. * gnu/packages/game-development.scm (fna): Delete variable. * gnu/packages/gl.scm (mojoshader-cs): Likewise. * gnu/packages/sdl.scm (sdl2-cs): Likewise.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm53
1 files changed, 0 insertions, 53 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9ddc72de77..889b435cfb 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -87,7 +87,6 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages m4)
- #:use-module (gnu packages mono)
#:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
@@ -2306,58 +2305,6 @@ specific knowledge of the hardware they are targeting.")
double-buffering.")
(license license:gpl2+)))
-(define-public fna
- (package
- (name "fna")
- (version "19.12.01")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/FNA-XNA/FNA")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1vdyi9hac24fqcs8kpj6yk36bf5rrl4dvlvdd9fc701fawcf6lrr"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; No tests.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'link-dep-src
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((sdl2 (assoc-ref inputs "sdl2-cs-src"))
- (mojoshader (assoc-ref inputs "mojoshader-src"))
- (faudio (assoc-ref inputs "faudio-src"))
- (theorafile (assoc-ref inputs "theorafile-src")))
- (symlink (string-append sdl2 "/src") "lib/SDL2-CS/src")
- (symlink (string-append mojoshader "/csharp") "lib/MojoShader/csharp")
- (symlink (string-append faudio "/csharp") "lib/FAudio/csharp")
- (symlink (string-append theorafile "/csharp") "lib/Theorafile/csharp"))))
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "make" "release")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (install-file "bin/Release/FNA.dll" (string-append out "/lib"))
- #t))))))
- (native-inputs
- (list mono))
- (inputs `(("sdl2-cs-src" ,(package-source sdl2-cs))
- ("mojoshader-src" ,(package-source mojoshader-cs))
- ("faudio-src" ,(package-source faudio))
- ("theorafile-src" ,(package-source theorafile))))
- (home-page "https://fna-xna.github.io/")
- (synopsis "Accuracy-focused XNA4 reimplementation")
- (description "FNA is a Microsoft XNA Game Studio 4.0 reimplementation that
-focuses solely on developing a fully accurate XNA4 runtime for the desktop.")
- (license (list license:ms-pl ; FNA
- license:lgpl2.1 ; LzxDecoder.cs
- ;; Mono.Xna:
- license:expat))))
-
(define-public libccd
(package
(name "libccd")