aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-18 11:54:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-18 11:54:54 +0200
commit993a4fbb7c3d1f9977e0789c21905fddd72241fd (patch)
tree899b928672607b9ad74dafd42eb2bfa048a041c4 /gnu/packages/game-development.scm
parent248965c91caf7d10433f090b4712a9b201968416 (diff)
parent7bc46ecc34ceb042ff890e5d306d0a2a736e891d (diff)
downloadguix-993a4fbb7c3d1f9977e0789c21905fddd72241fd.tar.gz
guix-993a4fbb7c3d1f9977e0789c21905fddd72241fd.zip
Merge remote-tracking branch 'origin/master' into wip-texlive
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7eac935a69..bb4c1d26bb 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -314,6 +314,16 @@ provide connectivity for client applications written in any language.")
(base32
"1pmvvm3sgnpngfa7884mqhq3fwdjh9sr0ca07ypnidcg0y341w53"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-pillow
+ (lambda _
+ ;; pillow's version is not in PIL.Image.VERSION anymore
+ (substitute* "nml/version_info.py"
+ (("from PIL import Image") "import PIL")
+ (("Image.VERSION") "PIL.__version__"))
+ #t)))))
(propagated-inputs
`(("python-pillow" ,python-pillow)
("python-ply" ,python-ply)))