aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fvwm.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
commit17dddeeee560527a8f30d37761949d658056cb09 (patch)
tree15b0b19c55787f556eb9b42c28d173bddc5435db /gnu/packages/fvwm.scm
parent331a09654eb7e9f6212b7e8469077fa7393e8b11 (diff)
parent6a9581741e4ee81226aeb2f1c997df76670a6aab (diff)
downloadguix-17dddeeee560527a8f30d37761949d658056cb09.tar.gz
guix-17dddeeee560527a8f30d37761949d658056cb09.zip
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/fvwm.scm')
-rw-r--r--gnu/packages/fvwm.scm19
1 files changed, 6 insertions, 13 deletions
diff --git a/gnu/packages/fvwm.scm b/gnu/packages/fvwm.scm
index 470f2e11e3..6509fb38a5 100644
--- a/gnu/packages/fvwm.scm
+++ b/gnu/packages/fvwm.scm
@@ -54,18 +54,11 @@
(let* ((out (assoc-ref outputs "out"))
(xsessions (string-append out "/share/xsessions")))
(mkdir-p xsessions)
- (with-output-to-file
- (string-append xsessions "/fvwm2.desktop")
- (lambda _
- (format #t
- "[Desktop Entry]~@
- Name=FVWM~@
- Comment=FVWM~@
- Exec=~a/bin/fvwm~@
- TryExec=~@*~a/bin/fvwm~@
- Icon=~@
- Type=Application~%"
- out))))
+ (make-desktop-entry-file
+ (string-append xsessions "/fvwm2.desktop")
+ #:name "FVWM"
+ #:exec (string-append out "/bin/" ,name)
+ #:comment '("FVWM")))
#t)))))
(native-inputs
`(("perl" ,perl)
@@ -86,5 +79,5 @@
(description
"FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
window manager for the X Window system.")
- (home-page "http://www.fvwm.org/")
+ (home-page "https://www.fvwm.org/")
(license gpl2+)))