aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authordan <i@dan.games>2024-09-23 07:04:00 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-26 13:17:47 +0900
commit1b4304ea29296e25026361ecf19226cf2f554836 (patch)
tree45b851c7545a3e3c1abc7fb6754a3dd2427ca555 /gnu/packages/freedesktop.scm
parent8576aaf5f90db9b385ea8cf6dc98bf3c062959dc (diff)
downloadguix-1b4304ea29296e25026361ecf19226cf2f554836.tar.gz
guix-1b4304ea29296e25026361ecf19226cf2f554836.zip
gnu: xdg-desktop-portal: Update to 1.18.4.
* gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/freedesktop.scm (xdg-desktop-portal): Update to 1.18.4. [patches]: Disable portal tests. [native-inputs]: Remove autoconf, automake, libtool and which. Add python, python-dbusmock, python-pytest and python-pytest-xdist. [inputs]: Add bubblewrap. [arguments]<#:configure-flags>: Replace “--with-systemd=no” with “-Dsystemd=disabled”. Change-Id: Ic9876565e9119443fedd082273be4f372ebce1d4 Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm25
1 files changed, 15 insertions, 10 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 993bb84ec6..f00f4b3956 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -136,6 +137,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
+ #:use-module (gnu packages virtualization)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -2986,7 +2988,7 @@ compatible with the well-known scripts of the same name.")
(define-public xdg-desktop-portal
(package
(name "xdg-desktop-portal")
- (version "1.16.0")
+ (version "1.18.4")
(source
(origin
(method url-fetch)
@@ -2995,18 +2997,21 @@ compatible with the well-known scripts of the same name.")
version "/xdg-desktop-portal-" version ".tar.xz"))
(sha256
(base32
- "06cczlh39kc41rvav06v37sad827y61rffy3v29i918ibj8sahav"))))
- (build-system gnu-build-system)
+ "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
+ ;; Disable portal tests since they try to use fuse.
+ (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
+ (build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
("glib:bin" ,glib "bin")
- ("which" ,which)
- ("gettext" ,gettext-minimal)))
+ ("gettext" ,gettext-minimal)
+ ("python" ,python)
+ ("python-dbusmock" ,python-dbusmock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-xdist" ,python-pytest-xdist)))
(inputs
- `(("gdk-pixbuf" ,gdk-pixbuf)
+ `(("bubblewrap" ,bubblewrap)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)
("flatpak" ,flatpak)
("fontconfig" ,fontconfig)
@@ -3018,7 +3023,7 @@ compatible with the well-known scripts of the same name.")
("fuse" ,fuse)))
(arguments
`(#:configure-flags
- (list "--with-systemd=no")
+ (list "-Dsystemd=disabled")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'po-chmod