aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-16 16:40:38 +0200
committerMarius Bakke <marius@gnu.org>2022-09-16 18:42:20 +0200
commit82d36421bc285da4d16a145301ceca0ce5ee9cde (patch)
tree92a002cde47a3c08c8ea448eab74103f4ae3bf68 /gnu/packages/fontutils.scm
parentd1c60dd89228197cd0a34c5316f287058f919857 (diff)
downloadguix-82d36421bc285da4d16a145301ceca0ce5ee9cde.tar.gz
guix-82d36421bc285da4d16a145301ceca0ce5ee9cde.zip
gnu: Add python-glyphsets.
* gnu/packages/fontutils.scm (python-glyphsets): New variable.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 6e89124d5e..39fc56b35d 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -603,6 +603,40 @@ process. FontParts is the successor of RoboFab.")
to UFOs and DesignSpace files via @code{defcon} and @code{designspaceLib}.")
(license license:asl2.0)))
+(define-public python-glyphsets
+ (package
+ (name "python-glyphsets")
+ (version "0.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "glyphsets" version))
+ (sha256
+ (base32
+ "1dc24i0hkd85gkkg3bqjhagjyw3xsqxazd86yh2l60c1wr5n9y6g"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'loosen-version-constraints
+ (lambda _
+ (substitute* "setup.py"
+ (("setuptools_scm>=4,<6\\.1")
+ "setuptools_scm>=4"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests/testglyphdata.py")
+ (invoke "pytest" "-vv" "tests/testusage.py")))))))
+ (native-inputs (list python-pytest python-setuptools-scm))
+ (propagated-inputs
+ (list python-defcon python-fonttools python-glyphslib))
+ (home-page "https://github.com/googlefonts/glyphsets/")
+ (synopsis "Evaluate coverage of glyph sets")
+ (description
+ "This package provides an API with data about glyph sets for many
+different scripts and languages.")
+ (license license:asl2.0)))
+
(define-public python-opentype-sanitizer
(package
(name "python-opentype-sanitizer")