aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-18 18:03:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-18 18:22:19 +0200
commite39b4902a07ff5a8cc5e6591e61ed08aa8b11482 (patch)
tree5c4312657ab122c6460b1bfb3821c941506ec1cf /gnu/packages/emulators.scm
parente598e2a57b3fc63f27ce2bac317f6865838727ae (diff)
downloadguix-e39b4902a07ff5a8cc5e6591e61ed08aa8b11482.tar.gz
guix-e39b4902a07ff5a8cc5e6591e61ed08aa8b11482.zip
gnu: scummvm: Use G-expressions.
* gnu/packages/emulators.scm (scummvm)[arguments]: Use G-expressions.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index f814dd6968..4d7710f8ea 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1515,21 +1515,21 @@ multi-system game/emulator system.")
(base32 "1s8psdn3a3hqvvfgmlfxrqqdw8hbr0zyrvirzsnzh6yxmgpvkbwg"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;require "git"
- #:configure-flags (list "--enable-release") ;for optimizations
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- ;; configure does not work followed by both "SHELL=..." and
- ;; "CONFIG_SHELL=..."; set environment variables instead
- (lambda* (#:key inputs outputs configure-flags #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bash (search-input-file inputs "/bin/bash"))
- (flags `(,(string-append "--prefix=" out)
+ (list
+ #:tests? #f ;require "git"
+ #:configure-flags #~(list "--enable-release") ;for optimizations
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ ;; configure does not work followed by both "SHELL=..." and
+ ;; "CONFIG_SHELL=..."; set environment variables instead
+ (lambda* (#:key inputs configure-flags #:allow-other-keys)
+ (let ((bash (search-input-file inputs "/bin/bash"))
+ (flags `(,(string-append "--prefix=" #$output)
,@configure-flags)))
- (setenv "SHELL" bash)
- (setenv "CONFIG_SHELL" bash)
- (apply invoke "./configure" flags)))))))
+ (setenv "SHELL" bash)
+ (setenv "CONFIG_SHELL" bash)
+ (apply invoke "./configure" flags)))))))
(native-inputs
(list nasm pkg-config))
(inputs