aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-26 09:32:50 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-19 21:45:47 +0900
commit7b6ab9ebe755ce3269c4445b1252ca67b3a70173 (patch)
treed896fa66010b308a49386fceabbf875d0817344c /gnu/packages/emulators.scm
parent8d5c1ef487aaebcca336a73fa0f0c9802c016580 (diff)
downloadguix-7b6ab9ebe755ce3269c4445b1252ca67b3a70173.tar.gz
guix-7b6ab9ebe755ce3269c4445b1252ca67b3a70173.zip
gnu: Add freedisksysrom.
* gnu/packages/emulators.scm (freedisksysrom): New variable. Change-Id: I6058d647ec0097a5b774afa3a999b8525325a648
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index edc2607e17..f0a60c0b49 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -3726,6 +3726,50 @@ on a Commodore C64, C128 etc.")
;; zlib license with an (non-)advertising clause.
(license license:zlib)))
+(define-public freedisksysrom
+ ;; There is no release; use the latest commit.
+ (let ((commit "0d5f95f109bb3aadf2bb9510bfda13879bbd5266")
+ (revision "0"))
+ (package
+ (name "freedisksysrom")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jamesathey/FreeDiskSysROM")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bmzmh3aq76jr31wn5lxvqvy9lpildxzqrvvqg1xxk5pvfjl8bip"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'build
+ (lambda _
+ (invoke "asm6f" "freedisksys.asm")))
+ (replace 'install
+ (lambda _
+ (let ((libexec (string-append #$output "/libexec")))
+ (install-file "freedisksys.bin" libexec)
+ (with-directory-excursion libexec
+ (symlink "freedisksys.bin" "disksys.rom"))))))))
+ (native-inputs (list asm6f))
+ (home-page "https://github.com/jamesathey/FreeDiskSysROM")
+ (synopsis "Implementation of the Famicom Disk System BIOS")
+ (description "FreeDiskSysROM aims to provide a replacement for the
+original @acronym{FDS, Famicom Disk System} BIOS (often referred to as
+@file{disksys.rom}) that can be freely redistributed and that is capable of
+running all published FDS software. FreeDiskSysROM is not currently fully
+completed and may not be sufficient for some FDS software. To track its
+status, consult
+@url{https://github.com/jamesathey/FreeDiskSysROM?tab=readme-ov-file#apis}.")
+ (license license:lgpl3+))))
+
(define-public qtrvsim
(package
(name "qtrvsim")
work of Maxime Devos shared under #54674, with some modifications by Attila Lendvai. * gnu/services/configuration.scm (normalize-field-type+def): New function. (define-configuration-helper) (define-configuration): Support new field format. * tests/services/configuration.scm (config-with-maybe-number->string): New function. ("maybe value serialization of the instance"): New test. ("maybe value serialization of the instance, unspecified"): New test. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Attila Lendvai 2021-06-29services: configuration: Allow specifying prefix for serializer names....Sometimes two configurations might have the same types for their field values, but the values might be serialized in two completely different ways (e.g. because the two programs have different configuration languages). An example of this would be the ‘serialize-boolean’ procedure in (gnu services mail) and (gnu services getmail). They both serialize a boolean value, but because the Dovecot’s configuration language has a different syntax to the configuration language for Getmail, two different procedures have to be defined. One way to workaround this would be to specify custom serializers for many fields in order to separate the serialization of the values that have the same type but serialize in different ways. This could get very tedious, especially if there are many configurations in the same module. Another way would be to move one of the configurations to its own module, like what was done with (gnu services getmail). However, this would mean that there would be multiple modules containing configurations for related programs, e.g. we have (gnu services mail) and (gnu services getmail), it doesn’t make much sense to keep the Getmail configuration in its own module. This patch will allow one to write something like this: (define-configuration foo-configuration (bar (string "bob") "Option bar.") (prefix bar-)) and the value of the ‘bar’ field would be serialized using a procedure named ‘bar-serialize-string’ instead of just ‘serialize-string’. * gnu/services/configuration.scm (define-maybe-helper): Accept ‘prefix’ argument for using serializer with custom prefix. (define-maybe): Pattern match on ‘prefix’ literal. (define-configuration-helper): Accept ‘prefix’ argument for using serializer with custom prefix. (define-configuration): Pattern match on ‘prefix’ literal. * tests/services/configuration.scm ("serialize-configuration with prefix"): New test. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Xinglu Chen 2021-05-17services: configuration: Add a define-maybe/no-serialization syntax....Before this change, using define-maybe along define-configuration with the no-serialization syntactic keyword would result in the following warning: warning: possibly unbound variable `VARIABLE-NAME' This change introduces the define-maybe/no-serialization variant that does away with defining a serialization helper procedure, which makes it possible to avoid the above warning. * gnu/services/configuration.scm (define-maybe/no-serialization): New syntax. (define-maybe-helper): New procedure. (define-maybe): Define syntax using the above procedure. * tests/services/configuration.scm (tests): Fix module name. (custom-number-serializer): Do not print to standard output. (maybe-number?, serialize-maybe-number): New procedures defined via the define-maybe macro. (config-with-maybe-number): New configuration. (serialize-number): New procedure. ("maybe value serialization"): New test. (maybe-string?): New procedure defined via the define-maybe/no-serialization macro. (config-with-maybe-string/no-serialization): New configuration. ("maybe value without serialization no procedure bound"): New test. Maxim Cournoyer 2021-05-08services: configuration: Add tests....* tests/services/configuration.scm: New file. * Makefile.am (SCM_TESTS): Register it. Maxim Cournoyer