aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 21:32:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 22:09:31 +0200
commitcc09b0ebfe9df79efd73130f221ec53560638840 (patch)
tree5212b01fb52b37febcd0edbf16a2ab513e81e957 /gnu/packages/emacs-xyz.scm
parent805505b6000051e5a940d8f076a556f1ecff40bd (diff)
downloadguix-cc09b0ebfe9df79efd73130f221ec53560638840.tar.gz
guix-cc09b0ebfe9df79efd73130f221ec53560638840.zip
gnu: emacs-org-super-agenda: Use G-expressions.
* gnu/packages/emacs-xyz.scm (emacs-org-super-agenda)[arguments]: Use G-expressions.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f2d65a79fc..54a57951bf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22540,20 +22540,21 @@ for defining recurring tasks and easily scheduling them.")
(base32 "07fv4zgmfc8ppppbr7ylhx89wcw6r6vmz4a6pg0iy4v7sn5pp1wa"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #true
- #:test-command '("test/run" "--debug")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'prepare-for-tests.el
- (lambda _
- (make-file-writable "test/test.el")
- (emacs-substitute-variables "test/test.el"
- ("org-super-agenda-test-results-file"
- (string-append (getcwd) "/test/results.el")))
- ;; The following tests fail.
- (substitute* "test/test.el"
- ((".* org-super-agenda-test--with-retained-sorting .*" all)
- (string-append all " (skip-unless nil)\n"))))))))
+ (list
+ #:tests? #true
+ #:test-command #~(list "test/run" "--debug")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'prepare-for-tests.el
+ (lambda _
+ (make-file-writable "test/test.el")
+ (emacs-substitute-variables "test/test.el"
+ ("org-super-agenda-test-results-file"
+ (string-append (getcwd) "/test/results.el")))
+ ;; The following tests fail.
+ (substitute* "test/test.el"
+ ((".* org-super-agenda-test--with-retained-sorting .*" all)
+ (string-append all " (skip-unless nil)\n"))))))))
(native-inputs
(list emacs-f util-linux))
(propagated-inputs