aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-02 20:27:38 +0800
committerAndrew Tropin <andrew@trop.in>2023-07-10 10:19:04 +0400
commit6663eb9aa7c438f011498fdd7caa0d46ffbab984 (patch)
tree1f116ae57969ee5b2628a62138fc89bc57180fbc /gnu/packages/emacs-xyz.scm
parent88027480b537b391b5089fb06889835510f33e59 (diff)
downloadguix-6663eb9aa7c438f011498fdd7caa0d46ffbab984.tar.gz
guix-6663eb9aa7c438f011498fdd7caa0d46ffbab984.zip
gnu: Add emacs-eldoc-box.
* gnu/packages/emacs-xyz.scm (emacs-eldoc-box): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index be4e7aa78e..8c688c186c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18626,6 +18626,28 @@ over a documented variable, it will print the one-line documentation for that
variable instead, to remind you of that variable's meaning.")
(license license:gpl3+)))
+(define-public emacs-eldoc-box
+ (package
+ (name "emacs-eldoc-box")
+ (version "1.10.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/casouri/eldoc-box")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "076bbn2nnrx02zk2hs4b39q0w3s7afbgfdxnwk2y2s8lkq1l6l87"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/casouri/eldoc-box")
+ (synopsis "Childframe doc for eglot and anything that uses eldoc")
+ (description
+ "This package displays ElDoc documentations in a childframe. The
+childfrme is selectable and scrollable with mouse, even thought the cursor is
+hidden.")
+ (license license:gpl3+)))
+
;; Tests for ert-runner have a circular dependency with ecukes, and therefore
;; cannot be run
(define-public emacs-ert-runner