aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-10 10:52:54 +0400
committerAndrew Tropin <andrew@trop.in>2023-07-11 20:06:10 +0400
commit3b77a06f3b2e4b3a78b8894d0349af316ae10ef4 (patch)
treefe06bad5e6c1b2171ea676d36b26a79cd772e218 /gnu/packages/emacs-xyz.scm
parent686a3ca7c531f1564bc4ddd95754531cd2e3db0e (diff)
downloadguix-3b77a06f3b2e4b3a78b8894d0349af316ae10ef4.tar.gz
guix-3b77a06f3b2e4b3a78b8894d0349af316ae10ef4.zip
gnu: Add emacs-starlit-theme.
* gnu/packages/emacs-xyz.scm (emacs-starlit-theme): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a9c00d458a..a2fbb7069f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -131,6 +131,7 @@
;;; Copyright © 2022-2023 Simon Josefsson <simon@josefsson.org>
;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
+;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32552,6 +32553,29 @@ a theme for Spacemacs. The theme comes with dark and light variants
and it should work well with 256 color terminals.")
(license license:gpl3+)))
+(define-public emacs-starlit-theme
+ (let ((commit "d6f327fb09497be7bee64d5d204d27f655cc5b04")
+ (revision "0"))
+ (package
+ (name "emacs-starlit-theme")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SFTtech/starlit-emacs")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "118b3ii9gpjq70q3qf0lyd53jp5a7qvhsl4bbjh4akck96cjdnnj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/SFTtech/starlit-emacs")
+ (synopsis "Deep blue and colorful Emacs theme like a clear night sky")
+ (description
+ "Starlit theme customizes your Emacs to be deep blue with bright colors
+from a starlit sky.")
+ (license license:gpl3+))))
+
(define-public emacs-elixir-mode
(package
(name "emacs-elixir-mode")