aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-10 18:10:53 +0400
committerAndrew Tropin <andrew@trop.in>2023-07-11 20:06:12 +0400
commit0cce3ac36e7acdf7502a9d8dd313bf40055e1484 (patch)
tree87a61ca6d25c003b0ec5ff6b20b81b9856f78018 /gnu/packages/emacs-xyz.scm
parentebaeeacc840eb48dc29e6a9630289790fd4394dc (diff)
downloadguix-0cce3ac36e7acdf7502a9d8dd313bf40055e1484.tar.gz
guix-0cce3ac36e7acdf7502a9d8dd313bf40055e1484.zip
gnu: Add emacs-sakura-theme.
* gnu/packages/emacs-xyz.scm (emacs-sakura-theme): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 154d4d1370..480096fb50 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5041,6 +5041,28 @@ DocView mode, and revisiting those PDF files later using the same mode will
restore the saved place.")
(license license:gpl3+)))
+(define-public emacs-sakura-theme
+ (package
+ (name "emacs-sakura-theme")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsfodder/emacs-theme-sakura")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nxj6gx5virv95sfxbasvr2mh427w5srzjsfawhf58ixif8wkhd0"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-autothemer))
+ (home-page "https://github.com/emacsfodder/emacs-theme-sakura")
+ (synopsis "Emacs theme of cherry blossoms")
+ (description
+ "Sakura Emacs theme is the rose tinted fork of @code{Creamsody},
+inspired by the Deep Purple.")
+ (license license:gpl3+)))
+
(define-public emacs-pdfgrep
;; XXX: Upstream does not tag releases. The commit below matches latest
;; version bump.