aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@suse.cz>2015-03-13 12:06:19 +0100
committerTomáš Čech <sleep_walker@gnu.org>2015-03-14 21:59:24 +0100
commit36fb36b55108d60c23fa7623a8b7c26f5cd97886 (patch)
treee5c0389506dc975df8824aa3a8ea4cb093b04c5c /gnu/packages/dns.scm
parent949f9aa100df192cfad9e81cb78e752a2820ab35 (diff)
downloadguix-36fb36b55108d60c23fa7623a8b7c26f5cd97886.tar.gz
guix-36fb36b55108d60c23fa7623a8b7c26f5cd97886.zip
gnu: Rename module dnsmasq to dns.
* gnu/packages/dnsmasq.scm: Rename to... * gnu/packages/dns.scm: ... this. Change module name accordingly. * gnu-system.am (GNU_SYSTEM_MODULES): Rename dnsmasq module to dns.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
new file mode 100644
index 0000000000..86f5945ee7
--- /dev/null
+++ b/gnu/packages/dns.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dns)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public dnsmasq
+ (package
+ (name "dnsmasq")
+ (version "2.72")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.thekelleys.org.uk/dnsmasq/dnsmasq-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1c80hq09hfm8cp5pirfb8wdlc7dqkp7zzmbmdaradcvlblzx42vx"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-delete 'configure %standard-phases)
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ ;; No 'check' target.
+ #:tests? #f))
+ (home-page "http://www.thekelleys.org.uk/dnsmasq/doc.html")
+ (synopsis "Small caching DNS proxy and DHCP/TFTP server")
+ (description
+ "Dnsmasq is a lightweight DNS forwarder and DHCP server. It is designed
+to provide DNS and optionally, DHCP, to a small network. It can serve the
+names of local machines which are not in the global DNS. The DHCP server
+integrates with the DNS server and allows machines with DHCP-allocated
+addresses to appear in the DNS with names configured either in each host or in
+a central configuration file. Dnsmasq supports static and dynamic DHCP leases
+and BOOTP/TFTP for network booting of diskless machines.")
+ ;; Source files only say GPL2 and GPL3 are allowed.
+ (license (list gpl2 gpl3))))