aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-21 16:49:58 -0400
committerJosselin Poiret <dev@jpoiret.xyz>2023-05-17 23:08:45 +0200
commitd19c7c2791dc01d678ec017ad83868d5629b53f6 (patch)
treee79cf024f190758e70d56b505885de1ecff91136 /gnu/packages/dlang.scm
parente041801e615d9194505d30093a7fdc8ac1d4a929 (diff)
downloadguix-d19c7c2791dc01d678ec017ad83868d5629b53f6.tar.gz
guix-d19c7c2791dc01d678ec017ad83868d5629b53f6.zip
gnu: ldc-bootstrap: Don't depend on tzdata.
* gnu/packages/dlang.scm (ldc-bootstrap)[inputs]: Remove tzdata. [native-inputs]: Add tzdata-for-tests. [arguments]: Forbid references to tzdata-for-tests. Reviewed-by: Ludovic Courtès <ludo@gnu.org> Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index fad3e683da..4735c53a77 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -159,7 +159,8 @@ to a minimal test case.")
(base32 "1kfs4fpr1525sv2ny10hlfppy8c075vjm8m649wr2b9411pkgfzx"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;skip in the bootstrap
+ `(#:disallowed-references (,tzdata-for-tests)
+ #:tests? #f ;skip in the bootstrap
#:build-type "Release"
#:configure-flags
(list "-GNinja")
@@ -187,7 +188,6 @@ to a minimal test case.")
(inputs
`(("libconfig" ,libconfig)
("libedit" ,libedit)
- ("tzdata" ,tzdata)
("zlib" ,zlib)))
(native-inputs
`(("lld-wrapper" ,(make-lld-wrapper lld-14 #:lld-as-ld? #t))
@@ -195,6 +195,7 @@ to a minimal test case.")
("ldc" ,gdmd)
("ninja" ,ninja)
("python-wrapper" ,python-wrapper)
+ ("tzdata" ,tzdata-for-tests)
("unzip" ,unzip)))
(home-page "http://wiki.dlang.org/LDC")
(synopsis "LLVM-based compiler for the D programming language")