aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-03 17:01:57 +0100
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 23:51:17 +0800
commit249db21652133744ba1b8a079d0709d838f2248e (patch)
tree8851823cfa74c5d6dbf318ebdb1e1cc9889adb72 /gnu/packages/django.scm
parentc37b16a2aefd36e5953498b412ccaee8aa223b9f (diff)
downloadguix-249db21652133744ba1b8a079d0709d838f2248e.tar.gz
guix-249db21652133744ba1b8a079d0709d838f2248e.zip
gnu: python-django-4.2: Update to 4.2.16. [security fixes]
This fixes CVE-2024-24680, CVE-2024-41989, CVE-2024-41990, CVE-2024-41991, CVE-2024-42005, CVE-2024-45230, CVE-2024-45231, CVE-2023-43665 and CVE-2023-46695. * gnu/packages/django.scm (python-django-4.2): Update to 4.2.16. [properties]: Add lint-hidden-cve property.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4404c8368d..4cf043f7c1 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -57,13 +57,13 @@
(define-public python-django-4.2
(package
(name "python-django")
- (version "4.2.5")
+ (version "4.2.16")
(source (origin
(method url-fetch)
(uri (pypi-uri "Django" version))
(sha256
(base32
- "1ha6c5j3pizbsfzw37r52lvdz8z5lblq4iwa99mpkdzz92aiqp2y"))))
+ "1b8xgwg3gjr974j60x3vgcpp85cg5dwhzqdpdbl8qh3cg311c5kg"))))
(build-system pyproject-build-system)
(arguments
'(#:test-flags
@@ -140,7 +140,9 @@ development and clean, pragmatic design. It provides many tools for building
any Web site. Django focuses on automating as much as possible and adhering
to the @dfn{don't repeat yourself} (DRY) principle.")
(license license:bsd-3)
- (properties `((cpe-name . "django")))))
+ (properties `((cpe-name . "django")
+ ;; This CVE seems fixed since 4.2.1.
+ (lint-hidden-cve . ("CVE-2023-31047"))))))
(define-public python-django-3.2
(package