aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-03-23 08:13:49 +0100
committerChristopher Baines <mail@cbaines.net>2024-03-24 10:02:44 +0000
commit939ed8515c75ee6501dd0278f6d18c235b05adc3 (patch)
tree1df605e583997c8161cfe2896e652590c55c0641 /gnu/packages/disk.scm
parent19cd76e3f7a7da7f42e5d576b624897570218928 (diff)
downloadguix-939ed8515c75ee6501dd0278f6d18c235b05adc3.tar.gz
guix-939ed8515c75ee6501dd0278f6d18c235b05adc3.zip
gnu: duc: Update style.
* gnu/packages/disk.scm (duc) [arguments]: Convert to list of G-Expressions. Change-Id: Iefcdcc55b1e71f7e866cb04795ef74f3b675cfce Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm55
1 files changed, 28 insertions, 27 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index ea18a98ab6..2e2c5739cc 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1567,33 +1567,34 @@ reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
(search-patches "duc-fix-test-sh.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (substitute* "src/duc/cmd-ui.c"
- (("ncursesw/ncurses.h") "ncurses.h"))
- (substitute* "examples/index.cgi"
- (("/usr/local/bin/duc")
- (string-append out "/bin/duc"))))))
- (add-after 'install 'install-examples
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (copy-recursively "examples" (string-append doc "/examples")))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (substitute* "test.sh"
- ;; Keep the test logs where --keep-failed can see them.
- (("^(DUC_TEST_DIR=).*" _ assign)
- (format #f "~a~a/test-directory~%" assign (getcwd)))
- ;; XXX ‘actual size’ differed on my system (a consistent 348160
- ;; bytes where the tests expect 540672). However, the ‘apparent
- ;; size’ matches, as does the actual test output. Good enough…?
- ((" [0-9]*B actual") " [0-9]*B actual"))
- (when tests?
- (invoke "./test.sh"))))))) ; no ‘check’ target
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (substitute* "src/duc/cmd-ui.c"
+ (("ncursesw/ncurses.h") "ncurses.h"))
+ (substitute* "examples/index.cgi"
+ (("/usr/local/bin/duc")
+ (string-append out "/bin/duc"))))))
+ (add-after 'install 'install-examples
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" #$name "-" #$version)))
+ (copy-recursively "examples" (string-append doc "/examples")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (substitute* "test.sh"
+ ;; Keep the test logs where --keep-failed can see them.
+ (("^(DUC_TEST_DIR=).*" _ assign)
+ (format #f "~a~a/test-directory~%" assign (getcwd)))
+ ;; XXX ‘actual size’ differed on my system (a consistent 348160
+ ;; bytes where the tests expect 540672). However, the ‘apparent
+ ;; size’ matches, as does the actual test output. Good enough…?
+ ((" [0-9]*B actual") " [0-9]*B actual"))
+ (when tests?
+ (invoke "./test.sh"))))))) ; no ‘check’ target
(native-inputs
(list autoconf automake libtool pkg-config))
(inputs