aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 10:32:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:44 +0100
commit6533ff252a4a6ac07d7b064bfb27e9ace4515774 (patch)
tree7c9aa13c319b660a9e5120326e800282c4a34313 /gnu/packages/disk.scm
parent0243721fb932c9226169b7fb00ebf8fb3f68519c (diff)
downloadguix-6533ff252a4a6ac07d7b064bfb27e9ace4515774.tar.gz
guix-6533ff252a4a6ac07d7b064bfb27e9ace4515774.zip
gnu: lf: Refresh package style.
* gnu/packages/disk.scm (lf): Adjust indentation. [arguments]: Use list style. Add <#:install-source?>. [native-inputs]: Sort alphabetically, move after arguments. [description]: Use texinfo style, adjust indentation. Change-Id: I7ce733139ca9a1514329cc1034de8f21c100b855
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm44
1 files changed, 25 insertions, 19 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 6f602d645f..10d546b918 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2023 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2023 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1296,29 +1297,34 @@ on your file system and offers to remove it. @command{rmlint} can find:
(package
(name "lf")
(version "31")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gokcehan/lf")
- (commit (string-append "r" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "03icsf4c3j7295s1d8s6srz5gf09a3lghgw3zfcd86p03zhkzsaf"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gokcehan/lf")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03icsf4c3j7295s1d8s6srz5gf09a3lghgw3zfcd86p03zhkzsaf"))))
(build-system go-build-system)
- (native-inputs
- (list go-github-com-mattn-go-runewidth go-golang-org-x-term
- go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2
- go-github-com-djherbis-times))
(arguments
- `(#:go ,go-1.18
- #:import-path "github.com/gokcehan/lf"))
+ (list
+ #:go go-1.18
+ #:install-source? #f
+ #:import-path "github.com/gokcehan/lf"))
+ (native-inputs
+ (list go-github-com-djherbis-times
+ go-github-com-gdamore-tcell-v2
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-term
+ go-gopkg-in-djherbis-times-v1))
(home-page "https://github.com/gokcehan/lf")
(synopsis "Console file browser similar to Ranger")
- (description "lf (as in \"list files\") is a terminal file manager
-written in Go. It is heavily inspired by ranger with some missing and
-extra features. Some of the missing features are deliberately omitted
-since they are better handled by external tools.")
+ (description
+ "@code{lf} (as in \"list files\") is a terminal file manager written in
+Go. It is heavily inspired by @code{ranger} with some missing and extra
+features. Some of the missing features are deliberately omitted since they
+are better handled by external tools.")
(license license:expat)))
(define-public xfe