aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dictionaries.scm
diff options
context:
space:
mode:
authorRunciter <runciter@whispers-vpn.org>2024-12-01 21:00:05 +0000
committerLudovic Courtès <ludo@gnu.org>2024-12-02 23:18:53 +0100
commit93833624fbd7e35e286b9948b341c395d6aacf3b (patch)
tree392c7d50925ec5a019c4216cc6eead6a07872a4d /gnu/packages/dictionaries.scm
parent68c502d942af24078a5648192bb8a4b9303782ab (diff)
downloadguix-93833624fbd7e35e286b9948b341c395d6aacf3b.tar.gz
guix-93833624fbd7e35e286b9948b341c395d6aacf3b.zip
gnu: Add freedict-tools.
* gnu/packages/dictionaries.scm (freedict-tools): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Change-Id: I141d30aea0e2c492b272be2ab9359e6b7569f932
Diffstat (limited to 'gnu/packages/dictionaries.scm')
-rw-r--r--gnu/packages/dictionaries.scm55
1 files changed, 54 insertions, 1 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 3f9b59c960..1a8da6e669 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -28,6 +28,7 @@
(define-module (gnu packages dictionaries)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
@@ -55,7 +56,10 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages tcl)
#:use-module (gnu packages web)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages dictd)
+ #:use-module (gnu packages speech)
+ #:use-module (gnu packages perl))
(define-public vera
@@ -466,3 +470,52 @@ in StarDict's format.")
for SKK Japanese input systems, and various dictionary files.
@file{SKK-JISYO.L} can be used with @code{emacs-ddskk} or @code{uim} package.")
(license license:gpl2+))))
+
+(define-public freedict-tools
+ (package
+ (name "freedict-tools")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/freedict/tools")
+ (commit "3596640e6e0582cc5fb76a342e5d8e7413aa4b34"))) ;"0.6.0" tag
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1raayynvn1j8x0ck8pnbbljl6zxnsyzzil7y54xz03dpj7k9w7mk"))))
+ (inputs (list espeak-ng
+ python
+ perl
+ gzip
+ tar
+ libxslt
+ dictd
+ perl-libxml))
+ (arguments
+ (list
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'set-prefix-in-makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("PREFIX \\?=.*")
+ (string-append "PREFIX = "
+ #$output "\n")))
+ (substitute* "mk/dicts.mk"
+ (("available_platforms := src dictd slob")
+ "available_platforms := dictd")))))))
+ (build-system gnu-build-system)
+ (synopsis "Build and manage FreeDict dictionaries")
+ (description
+ "FreeDict is a project that offers over 140 free
+dictionaries in about 45 languages, with the right to study, change and
+modify them. You can use them offline on your computer or mobile phone
+and export them to any format and application.
+
+In order to limit store size and build complexity, only the build
+targets that build dictionaries in dictd format are retained when this
+Guix package is installed.")
+ (home-page "https://freedict.org")
+ (license license:gpl2+)))