aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cyrus-sasl.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-12-04 01:02:00 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:21 -0400
commitbb8be806b5e6bcbe83ae1ebfce71a3881cf23015 (patch)
treefbca1262a56155f303d9654c8f35b82d7beb98a2 /gnu/packages/cyrus-sasl.scm
parentcccbe0a7cb80b10aec32a12236fff5045d791fa5 (diff)
downloadguix-bb8be806b5e6bcbe83ae1ebfce71a3881cf23015.tar.gz
guix-bb8be806b5e6bcbe83ae1ebfce71a3881cf23015.zip
gnu: cairo: Enable some features.
* gnu/packages/gtk.scm (cairo) [native-inputs]: Add gobject-introspection. [inputs]: Add libdrm. Remove xorgproto and zlib. [propagated-inputs]: Add libxcb. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/cyrus-sasl.scm')
0 files changed, 0 insertions, 0 deletions
'>gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2167,20 +2167,21 @@ This package can be used to create @code{favicon.ico} files for web sites.")
"02zmb62g0yx6rfz4w1isyzfrckv5i7dzyz26rp2mspbx9w6v8j4r"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DAVIF_CODEC_AOM=ON" "-DAVIF_CODEC_DAV1D=ON"
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '("-DAVIF_CODEC_RAV1E=ON")
- '())
- "-DAVIF_BUILD_TESTS=ON")
+ (list #:configure-flags
+ #~'("-DAVIF_CODEC_AOM=ON" "-DAVIF_CODEC_DAV1D=ON"
+ #$@(if (string-prefix? "x86_64"
+ (or (%current-target-system)
+ (%current-system)))
+ '("-DAVIF_CODEC_RAV1E=ON")
+ '())
+ "-DAVIF_BUILD_TESTS=ON")
#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-readme
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/libavif-" ,version)))
- (install-file "../source/README.md" doc)))))))
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-readme
+ (lambda _
+ (let ((doc (string-append #$output "/share/doc/libavif-"
+ #$(package-version this-package))))
+ (install-file "../source/README.md" doc)))))))
(native-inputs (list googletest))
(inputs
(append