aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-14 14:33:25 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:59 +0200
commit3e580395a8ae03561e4df567d2706fd1acde7983 (patch)
tree66f494c6bfeaf7e37297855bf76a1e4ba2650538 /gnu/packages/curl.scm
parent17cf9fc0c15f5c2d9e4729221c59052f481a41ef (diff)
downloadguix-3e580395a8ae03561e4df567d2706fd1acde7983.tar.gz
guix-3e580395a8ae03561e4df567d2706fd1acde7983.zip
gnu: curl: Re-order fields.
* gnu/packages/curl.scm (curl): Order the fields in the more customary ordering. Change-Id: I7caa3c4d27668a29375166e5553ffc4112c85783
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 1849a83435..ce12bc0e5d 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -75,25 +75,9 @@
(base32
"1sqfflilf7mcz1g03lazyr6v6pf1rsrzprrknsir10hdwawqvas2"))
(patches (search-patches "curl-use-ssl-cert-env.patch"))))
- (build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
- (inputs
- (list gnutls libidn mit-krb5 `(,nghttp2 "lib") zlib))
- (native-inputs
- (list nghttp2 perl pkg-config python-minimal-wrapper))
- (native-search-paths
- ;; These variables are introduced by curl-use-ssl-cert-env.patch.
- (list $SSL_CERT_DIR
- $SSL_CERT_FILE
- ;; Note: This search path is respected by the `curl` command-line
- ;; tool only. Patching libcurl to read it too would bring no
- ;; advantages and require maintaining a more complex patch.
- (search-path-specification
- (variable "CURL_CA_BUNDLE")
- (file-type 'regular)
- (separator #f) ;single entry
- (files '("etc/ssl/certs/ca-certificates.crt")))))
+ (build-system gnu-build-system)
(arguments
(list
#:disallowed-references '("doc")
@@ -163,6 +147,22 @@
(display "1501\n" port)
(close port)))))
#~()))))
+ (native-inputs
+ (list nghttp2 perl pkg-config python-minimal-wrapper))
+ (inputs
+ (list gnutls libidn mit-krb5 `(,nghttp2 "lib") zlib))
+ (native-search-paths
+ ;; These variables are introduced by curl-use-ssl-cert-env.patch.
+ (list $SSL_CERT_DIR
+ $SSL_CERT_FILE
+ ;; Note: This search path is respected by the `curl` command-line
+ ;; tool only. Patching libcurl to read it too would bring no
+ ;; advantages and require maintaining a more complex patch.
+ (search-path-specification
+ (variable "CURL_CA_BUNDLE")
+ (file-type 'regular)
+ (separator #f) ;single entry
+ (files '("etc/ssl/certs/ca-certificates.crt")))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,