aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-18 13:55:47 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-18 13:56:07 +0100
commit186de634a79c94d4524f477675c67ae533caeb55 (patch)
tree615ac5a546acc36bca752d729c313170c4aa28b9 /gnu/packages/curl.scm
parentdb5584dd1117fb3bf926a1daaf8fb561a38839e3 (diff)
downloadguix-186de634a79c94d4524f477675c67ae533caeb55.tar.gz
guix-186de634a79c94d4524f477675c67ae533caeb55.zip
gnu: curl: Enable more verbose test output.
* gnu/packages/curl.scm (curl)[arguments]: Fold 'patch-runtests' phase into 'check' phase, and replace the standard 'check' phase. Run "make -C tests test".
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 1a428d54ff..f595e7259c 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -61,11 +61,16 @@
`(#:configure-flags '("--with-gnutls" "--with-gssapi")
;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
#:phases
- (alist-cons-before
- 'check 'patch-runtests
+ (alist-replace
+ 'check
(lambda _
- (substitute* "tests/runtests.pl"
- (("/bin/sh") (which "sh"))))
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh")))
+
+ ;; The top-level "make check" does "make -C tests quiet-test", which
+ ;; is too quiet. Use the "test" target instead, which is more
+ ;; verbose.
+ (zero? (system* "make" "-C" "tests" "test")))
%standard-phases)))
(synopsis "Command line tool for transferring data with URL syntax")
(description